Add preliminary support for ADM5120 big-endian targets (Zyxel P-335WT for instance...
[openwrt/svn-archive/archive.git] / target / linux / adm5120eb-2.6 / Makefile
diff --git a/target/linux/adm5120eb-2.6/Makefile b/target/linux/adm5120eb-2.6/Makefile
new file mode 100644 (file)
index 0000000..7da6e5c
--- /dev/null
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=adm5120eb
+BOARDNAME:=ADMtek 5120 (Big Endian)
+FEATURES:=squashfs broken
+
+define Target/Description
+       Build firmware images for ADMTek ADM5120 based boards running in big-endian mode
+       (e.g : ZyXEL Prestige 335WT ...)
+endef
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))