Merge branch 'adm8668'
[openwrt/svn-archive/archive.git] / target / linux / adm8668 / Makefile
diff --git a/target/linux/adm8668/Makefile b/target/linux/adm8668/Makefile
new file mode 100644 (file)
index 0000000..9021e39
--- /dev/null
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=adm8668
+BOARDNAME:=Infineon WildPass ADM8668
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.36
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
+# kmod-switch kmod-diag nvram
+
+define Target/Description
+       Build firmware images for Infineon WildPass (ADM8668) based routers
+       (e.g. T-Mobile branded Linksys WRTU54G-TM)
+endef
+
+$(eval $(call BuildTarget))