amazon: remove 2.6.3{0,2} support
[openwrt/svn-archive/archive.git] / target / linux / amazon / patches-2.6.30 / 100-board.patch
diff --git a/target/linux/amazon/patches-2.6.30/100-board.patch b/target/linux/amazon/patches-2.6.30/100-board.patch
deleted file mode 100644 (file)
index 66d5fd6..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -60,6 +60,22 @@ config BCM47XX
-       help
-        Support for BCM47XX based boards
-+config AMAZON
-+      bool "Amazon support (EXPERIMENTAL)"
-+      depends on EXPERIMENTAL
-+      select DMA_NONCOHERENT
-+      select IRQ_CPU
-+      select CEVT_R4K
-+      select CSRC_R4K
-+      select SYS_HAS_CPU_MIPS32_R1
-+      select SYS_HAS_CPU_MIPS32_R2
-+      select HAVE_STD_PC_SERIAL_PORT
-+      select SYS_SUPPORTS_BIG_ENDIAN
-+      select SYS_SUPPORTS_32BIT_KERNEL
-+      select SYS_HAS_EARLY_PRINTK
-+      select HW_HAS_PCI
-+      select SWAP_IO_SPACE
-+
- config MIPS_COBALT
-       bool "Cobalt Server"
-       select CEVT_R4K
-@@ -633,6 +649,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
- endchoice
-+source "arch/mips/amazon/Kconfig"
- source "arch/mips/alchemy/Kconfig"
- source "arch/mips/basler/excite/Kconfig"
- source "arch/mips/jazz/Kconfig"
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -283,6 +283,13 @@ libs-$(CONFIG_MIPS_XXS1500)       += arch/mips
- load-$(CONFIG_MIPS_XXS1500)   += 0xffffffff80100000
- #
-+# Infineon AMAZON
-+#
-+core-$(CONFIG_AMAZON)         += arch/mips/amazon/
-+cflags-$(CONFIG_AMAZON)       += -I$(srctree)/arch/mips/include/asm/mach-amazon
-+load-$(CONFIG_AMAZON)         += 0xffffffff80002000
-+
-+#
- # Cobalt Server
- #
- core-$(CONFIG_MIPS_COBALT)    += arch/mips/cobalt/