[ar71xx] dir-825-b1: Fix wholeflash images: Attempting to flash a wholeflash (-openwr...
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / generic / profiles / d-link.mk
index 1691cade2fddb3d0542fa7133a37bbc8a0ae075d..8fcc77f0f100c9719d0a072b15f040e598084139 100644 (file)
@@ -68,28 +68,46 @@ endef
 
 define Profile/DIR825B1/Description
        Package set optimized for the D-Link DIR-825 rev. B1.
+       WARNING: Flashing wholeflash (openwrt optimized) image may brick your router
+       .  This will occur if your openwrt optimized image is larger than the
+       maximum size for a regular dir-825 b1 image (a little more than 6MB).
+       Please flash a TOWHOLEFLASH image instead of this image before flashing
+a 
+       WHOLEFLASH image.
+endef
+
+$(eval $(call Profile,DIR825B1))
+
+define Profile/DIR825B1_TOWHOLEFLASH
+       NAME:=D-Link DIR-825 rev. B1 designed for transition to image using whole flash
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR825B1_TOWHOLEFLASH/Description
+       Package set optimized for the D-Link DIR-825 rev. B1. design for transtion to
+       image using whole flash.
        Copies the calibration data to the last erase block so that, if desired,
        an image optimized for use with OpenWrt (access to full flash) can be flashed.
 endef
 
-$(eval $(call Profile,DIR825B1))
+$(eval $(call Profile,DIR825B1_TOWHOLEFLASH))
 
-define Profile/DIR825B1_OPENWRT
-       NAME:=D-Link DIR-825 rev. B1 optimized for OpenWrt
+define Profile/DIR825B1_WHOLEFLASH
+       NAME:=D-Link DIR-825 rev. B1 optimized for OpenWrt which uses full 8M flash
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
 endef
 
-define Profile/DIR825B1_OPENWRT/Description
-       Package set optimized for the D-Link DIR-825 rev. B1. running OpenWrt
+define Profile/DIR825B1_WHOLEFLASH/Description
+       Package set optimized for the D-Link DIR-825 rev. B1. using wholeflash
        Can only be flashed from OpenWrt because it requires that the calibration data
        be on the last sector of the flash (which the 'standard' version that can be flashed from
        stock will ensure).     
 endef
 
-$(eval $(call Profile,DIR825B1_OPENWRT))
+$(eval $(call Profile,DIR825B1_WHOLEFLASH))
 
 define Profile/DIR825B1_TOSTOCK
-       NAME:=D-Link DIR-825 rev. B1 that undoes OpenWrt optimization
+       NAME:=D-Link DIR-825 rev. B1 that undoes OpenWrt optimization (i.e. wholeflash)
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
 endef