[ar71xx] create firmware image for the RouterStation Pro, and add a profile for it...
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / profiles / ubnt.mk
index ac9ef3619db4c2a1596dc2d6088c4faf1ff65c88..849e3c2edd84cdd0520b12b2210f2d7c75dbc368 100644 (file)
@@ -15,3 +15,25 @@ define Profile/UBNTRS/Description
 endef
 
 $(eval $(call Profile,UBNTRS))
+
+define Profile/UBNTRSPRO
+       NAME:=Ubiquiti RouterStation Pro
+       PACKAGES:=kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTRSPRO/Description
+       Package set optimized for the Ubiquiti RouterStation Pro.
+endef
+
+$(eval $(call Profile,UBNTRSPRO))
+
+define Profile/UBNT
+       NAME:=Ubiquiti Products
+       PACKAGES:=kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNT/Description
+       Build images for all Ubiquiti products (including LS-SR71, RouterStation and RouterStation Pro)
+endef
+
+$(eval $(call Profile,UBNT))