Remove a debug statement from trx.c, add config changes for at91
[openwrt/svn-archive/archive.git] / target / linux / at91-2.6 / image / Makefile
index 73a281b8085cd5c32377854c1822289314dbc4d1..b498059a57cdc2a4b2d5911c372cd8090e656a0b 100644 (file)
@@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Build/Clean
-       $(MAKE) -C romboot clean
+#      $(MAKE) -C romboot clean
+       $(MAKE) -C dfboot clean
        $(MAKE) -C u-boot clean
 endef
 
 define Build/Compile
-       $(MAKE) -C romboot compile
-#      $(MAKE) -C u-boot configure
+#      $(MAKE) -C romboot compile
+       $(MAKE) -C dfboot compile
        $(MAKE) -C u-boot compile
        $(KDIR)/u-boot-1.1.4/tools/ubparams
        cp params $(KDIR)
@@ -23,8 +24,8 @@ endef
 
 define Image/Prepare
   cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
-       cp $(KDIR)/romboot/romboot.bin $(KDIR)/romboot.bin
-       cp $(KDIR)/romboot/rbptest.bin $(KDIR)/rbptest.bin
+       cp $(KDIR)/dfboot/dfboot.bin $(KDIR)/dfboot.bin
+       cp $(KDIR)/dfboot/dfbptest.bin $(KDIR)/dfbptest.bin
        cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
        dd if=$(KDIR)/u-boot.bin of=$(KDIR)/u-boot.block bs=100k count=1 conv=sync
        cat $(KDIR)/u-boot.block $(KDIR)/params > $(KDIR)/u-boot.full
@@ -38,8 +39,8 @@ define Image/Build
        dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=8448 conv=sync
        dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=8448 conv=sync
        cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
-       $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/romboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
-       cp $(KDIR)/rbptest.bin $(BIN_DIR)
+       $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
+       cp $(KDIR)/dfbptest.bin $(BIN_DIR)
        $(call Image/Build/$(1),$(1))
 endef