Added module to generate u-boot config file. Added platform overrides
[openwrt/svn-archive/archive.git] / target / linux / at91-2.6 / image / u-boot / ubclient / Makefile
diff --git a/target/linux/at91-2.6/image/u-boot/ubclient/Makefile b/target/linux/at91-2.6/image/u-boot/ubclient/Makefile
new file mode 100644 (file)
index 0000000..c79260e
--- /dev/null
@@ -0,0 +1,15 @@
+#
+
+all: ubpar
+
+crc32.c:
+       ln -s ../lib_generic/crc32.c ./
+
+%.o: %.c
+       $(CC) -I ../include $(CFLAGS) $(EXTRA_FLAGS) -c -o $@ $^
+
+ubpar: ubpar.o crc32.o
+       $(CC) -o $@ $^
+
+clean:
+       rm -f *.o ubpar