[at91] prepare TQ-Components TQMa9263 kernel support
[openwrt/svn-archive/archive.git] / target / linux / at91 / patches / 700-tqma9263-support.patch
diff --git a/target/linux/at91/patches/700-tqma9263-support.patch b/target/linux/at91/patches/700-tqma9263-support.patch
new file mode 100644 (file)
index 0000000..941b4a6
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/arch/arm/mach-at91/Kconfig
++++ b/arch/arm/mach-at91/Kconfig
+@@ -317,6 +317,12 @@
+       help
+         Select this if you are using the Adeneo Neocore 926 board.
++config MACH_TQMA9263
++      bool "TQ Components TQMa9263 board"
++      help
++        Select this if you are using the an TQ Components TQMa9263 board.
++        <http://www.tq-components.com/>
++
+ endif
+ # ----------------------------------------------------------
+--- a/arch/arm/mach-at91/Makefile
++++ b/arch/arm/mach-at91/Makefile
+@@ -55,6 +55,7 @@
+ obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
+ obj-$(CONFIG_MACH_USB_A9263)  += board-usb-a9263.o
+ obj-$(CONFIG_MACH_NEOCORE926) += board-neocore926.o
++obj-$(CONFIG_MACH_TQMA9263)   += board-tqma9263.o
+ # AT91SAM9RL board-specific support
+ obj-$(CONFIG_MACH_AT91SAM9RLEK)       += board-sam9rlek.o