[atheros] Generate suitable images for the UBNT PicoStation2
[openwrt/svn-archive/archive.git] / target / linux / atheros / image / Makefile
index 73657334ee863da7c2c87a4d6657f5ebc2c0742f..e2f6315705ef84c93fb7f5feb84404a429b4adfa 100644 (file)
@@ -35,6 +35,12 @@ define Image/Build
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
                -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin
 
+       -$(STAGING_DIR_HOST)/bin/mkfwimage \
+               -B XS2-8 -v XS2.ar2316.OpenWrt.$(REVISION) \
+               -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+               -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+               -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-8-$(1).bin
+
        -$(STAGING_DIR_HOST)/bin/mkmylofw -B np25g \
                -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz  \
                -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \