atheros: trailing statements fixes
[openwrt/svn-archive/archive.git] / target / linux / atheros / patches-3.10 / 101-early-printk-support.patch
index 2346e24918ba9769efffca6afad2d80244d3d067..3daa0117f7435b5c479f49bcabf8a3997e577409 100644 (file)
@@ -1,6 +1,6 @@
 --- /dev/null
 +++ b/arch/mips/ar231x/early_printk.c
-@@ -0,0 +1,44 @@
+@@ -0,0 +1,46 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
 +                      base = (void __iomem *)(KSEG1ADDR(AR531X_UART0));
 +      }
 +
-+      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++              ;
 +      prom_uart_wr(base, UART_TX, ch);
-+      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++              ;
 +}
 +
 --- a/arch/mips/ar231x/Makefile