fix uboot not building
[openwrt/svn-archive/archive.git] / target / linux / avr32 / image / u-boot / Makefile
index ec4f7fbbbb629cecc74d75e6df0014dcb86cb7fe..a24efc4c47b8d874f492d2b39f9c82a2e4c6a52b 100644 (file)
@@ -29,7 +29,8 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(CONFIG_AVR32_UBOOT_TARGET).bin bs=64k conv=sync
+       mkdir -p $(BIN_DIR)
+       dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(UBOOT_CONFIG).bin bs=64k conv=sync
 endef
 
 $(eval $(call Build/DefaultTargets))