strip the kernel version suffix from target directories, except for brcm-2.4 (the...
[openwrt/svn-archive/archive.git] / target / linux / brcm-2.4 / Makefile
index e15eb09b5f65846d1192c4b741df838cc50bd6c3..ed7336daeaca26ac004236152d909d294c3c68ea 100644 (file)
@@ -6,9 +6,22 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.4.32
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
+ARCH:=mipsel
+BOARD:=brcm-2.4
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs
+
+define Target/Description
+       Build firmware images for Broadcom based routers
+       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+endef
+
+KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))