brcm47xx: add mips74k subtarget for newer devices
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx / mips74k / profiles / 100-Broadcom-b43.mk
diff --git a/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk
new file mode 100644 (file)
index 0000000..7d3c6a7
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-b43
+  NAME:=Broadcom SoC, BCM43xx WiFi (b43)
+  PACKAGES:=kmod-bgmac kmod-b43
+endef
+
+define Profile/Broadcom-mips74k-b43/Description
+       Package set for devices with BCM43xx WiFi including mac80211 and b43
+       driver.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-b43))
+