[brcm47xx] refresh 2.6.23 patches
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx / patches-2.6.23 / 130-remove_scache.patch
index b30f7978163443b1ee17370f98087df3fc16e092..8befbf1a85dfbe680b5dec7f55b3180b167ee45c 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.23.17/arch/mips/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/Kconfig
-+++ linux-2.6.23.17/arch/mips/Kconfig
-@@ -192,7 +192,6 @@ config MIPS_MALTA
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -192,7 +192,6 @@
        select I8259
        select MIPS_BOARDS_GEN
        select MIPS_BONITO64
@@ -10,7 +8,7 @@ Index: linux-2.6.23.17/arch/mips/Kconfig
        select PCI_GT64XXX_PCI0
        select MIPS_MSC
        select SWAP_IO_SPACE
-@@ -1281,13 +1280,6 @@ config IP22_CPU_SCACHE
+@@ -1281,13 +1280,6 @@
        bool
        select BOARD_SCACHE
  
@@ -24,11 +22,9 @@ Index: linux-2.6.23.17/arch/mips/Kconfig
  config R5000_CPU_SCACHE
        bool
        select BOARD_SCACHE
-Index: linux-2.6.23.17/arch/mips/kernel/cpu-probe.c
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/kernel/cpu-probe.c
-+++ linux-2.6.23.17/arch/mips/kernel/cpu-probe.c
-@@ -701,6 +701,8 @@ static inline void cpu_probe_mips(struct
+--- a/arch/mips/kernel/cpu-probe.c
++++ b/arch/mips/kernel/cpu-probe.c
+@@ -701,6 +701,8 @@
                break;
        case PRID_IMP_25KF:
                c->cputype = CPU_25KF;
@@ -37,11 +33,9 @@ Index: linux-2.6.23.17/arch/mips/kernel/cpu-probe.c
                break;
        case PRID_IMP_34K:
                c->cputype = CPU_34K;
-Index: linux-2.6.23.17/arch/mips/mm/c-r4k.c
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/mm/c-r4k.c
-+++ linux-2.6.23.17/arch/mips/mm/c-r4k.c
-@@ -1101,7 +1101,6 @@ static void __init loongson2_sc_init(voi
+--- a/arch/mips/mm/c-r4k.c
++++ b/arch/mips/mm/c-r4k.c
+@@ -1101,7 +1101,6 @@
  
  extern int r5k_sc_init(void);
  extern int rm7k_sc_init(void);
@@ -49,7 +43,7 @@ Index: linux-2.6.23.17/arch/mips/mm/c-r4k.c
  
  static void __init setup_scache(void)
  {
-@@ -1155,29 +1154,17 @@ static void __init setup_scache(void)
+@@ -1155,29 +1154,17 @@
  #endif
  
        default:
@@ -84,11 +78,9 @@ Index: linux-2.6.23.17/arch/mips/mm/c-r4k.c
        /* compute a couple of other cache variables */
        c->scache.waysize = scache_size / c->scache.ways;
  
-Index: linux-2.6.23.17/arch/mips/mm/Makefile
-===================================================================
---- linux-2.6.23.17.orig/arch/mips/mm/Makefile
-+++ linux-2.6.23.17/arch/mips/mm/Makefile
-@@ -31,6 +31,5 @@ obj-$(CONFIG_CPU_VR41XX)     += c-r4k.o cex-
+--- a/arch/mips/mm/Makefile
++++ b/arch/mips/mm/Makefile
+@@ -31,6 +31,5 @@
  obj-$(CONFIG_IP22_CPU_SCACHE) += sc-ip22.o
  obj-$(CONFIG_R5000_CPU_SCACHE)  += sc-r5k.o
  obj-$(CONFIG_RM7000_CPU_SCACHE)       += sc-rm7k.o