brcm47xx: add patches for kernel 2.6.36
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx / patches-2.6.36 / 110-flash_map.patch
diff --git a/target/linux/brcm47xx/patches-2.6.36/110-flash_map.patch b/target/linux/brcm47xx/patches-2.6.36/110-flash_map.patch
new file mode 100644 (file)
index 0000000..495570f
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -319,6 +319,12 @@ config MTD_CFI_FLAGADM
+         Mapping for the Flaga digital module. If you don't have one, ignore
+         this setting.
++config MTD_BCM47XX
++      tristate "BCM47xx flash device"
++      depends on MIPS && MTD_CFI && BCM47XX
++      help
++        Support for the flash chips on the BCM947xx board.
++
+ config MTD_SOLUTIONENGINE
+       tristate "CFI Flash device mapped on Hitachi SolutionEngine"
+       depends on SUPERH && SOLUTION_ENGINE && MTD_CFI && MTD_REDBOOT_PARTS
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -29,6 +29,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM)   += pmcms
+ obj-$(CONFIG_MTD_PCMCIA)      += pcmciamtd.o
+ obj-$(CONFIG_MTD_RPXLITE)     += rpxlite.o
+ obj-$(CONFIG_MTD_TQM8XXL)     += tqm8xxl.o
++obj-$(CONFIG_MTD_BCM47XX)     += bcm47xx-flash.o
+ obj-$(CONFIG_MTD_SA1100)      += sa1100-flash.o
+ obj-$(CONFIG_MTD_SBC_GXX)     += sbc_gxx.o
+ obj-$(CONFIG_MTD_SC520CDP)    += sc520cdp.o