remove generic linux 2.4 support
[openwrt/svn-archive/archive.git] / target / linux / generic-2.4 / files / crypto / ocf / ep80579 / Makefile
diff --git a/target/linux/generic-2.4/files/crypto/ocf/ep80579/Makefile b/target/linux/generic-2.4/files/crypto/ocf/ep80579/Makefile
deleted file mode 100644 (file)
index 9aab295..0000000
+++ /dev/null
@@ -1,119 +0,0 @@
-#########################################################################
-#
-#  Targets supported
-#  all     - builds everything and installs
-#  install - identical to all
-#  depend  - build dependencies
-#  clean   - clears derived objects except the .depend files
-#  distclean- clears all derived objects and the .depend file
-#  
-# @par
-# This file is provided under a dual BSD/GPLv2 license.  When using or 
-#   redistributing this file, you may do so under either license.
-# 
-#   GPL LICENSE SUMMARY
-# 
-#   Copyright(c) 2007,2008,2009 Intel Corporation. All rights reserved.
-# 
-#   This program is free software; you can redistribute it and/or modify 
-#   it under the terms of version 2 of the GNU General Public License as
-#   published by the Free Software Foundation.
-# 
-#   This program is distributed in the hope that it will be useful, but 
-#   WITHOUT ANY WARRANTY; without even the implied warranty of 
-#   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#   General Public License for more details.
-# 
-#   You should have received a copy of the GNU General Public License 
-#   along with this program; if not, write to the Free Software 
-#   Foundation, Inc., 51 Franklin St - Fifth Floor, Boston, MA 02110-1301 USA.
-#   The full GNU General Public License is included in this distribution 
-#   in the file called LICENSE.GPL.
-# 
-#   Contact Information:
-#   Intel Corporation
-# 
-#   BSD LICENSE 
-# 
-#   Copyright(c) 2007,2008,2009 Intel Corporation. All rights reserved.
-#   All rights reserved.
-# 
-#   Redistribution and use in source and binary forms, with or without 
-#   modification, are permitted provided that the following conditions 
-#   are met:
-# 
-#     * Redistributions of source code must retain the above copyright 
-#       notice, this list of conditions and the following disclaimer.
-#     * Redistributions in binary form must reproduce the above copyright 
-#       notice, this list of conditions and the following disclaimer in 
-#       the documentation and/or other materials provided with the 
-#       distribution.
-#     * Neither the name of Intel Corporation nor the names of its 
-#       contributors may be used to endorse or promote products derived 
-#       from this software without specific prior written permission.
-# 
-#   THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
-#   "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT 
-#   LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR 
-#   A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT 
-#   OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 
-#   SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT 
-#   LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, 
-#   DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY 
-#   THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
-#   (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE 
-#   OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# 
-# 
-#  version: Security.L.1.0.2-229
-############################################################################
-
-
-####################Common variables and definitions########################
-
-ifndef ICP_ROOT
-$(warning ICP_ROOT is undefined. Please set the path to EP80579 release package directory \
-        "-> setenv ICP_ROOT <path>")
-all fastdep:
-       :
-else
-
-ifndef KERNEL_SOURCE_ROOT
-$(error KERNEL_SOURCE_ROOT is undefined. Please set the path to the kernel source directory \
-        "-> setenv KERNEL_SOURCE_ROOT <path>")
-endif
-
-# Ensure The ENV_DIR environmental var is defined.
-ifndef ICP_ENV_DIR
-$(error ICP_ENV_DIR is undefined. Please set the path to EP80579 driver environment.mk file \
-        "-> setenv ICP_ENV_DIR <path>")
-endif
-
-#Add your project environment Makefile
-include ${ICP_ENV_DIR}/environment.mk
-
-#include the makefile with all the default and common Make variable definitions
-include ${ICP_BUILDSYSTEM_PATH}/build_files/common.mk
-
-#Add the name for the executable, Library or Module output definitions
-OUTPUT_NAME= icp_ocf
-
-# List of Source Files to be compiled 
-SOURCES= icp_common.c icp_sym.c icp_asym.c icp_ocf_linux.c
-
-#common includes between all supported OSes
-INCLUDES= -I ${ICP_API_DIR} -I${ICP_LAC_API} \
--I${ICP_OCF_SRC_DIR}
-
-# The location of the os level makefile needs to be changed.
-include ${ICP_ENV_DIR}/${ICP_OS}_${ICP_OS_LEVEL}.mk
-
-# On the line directly below list the outputs you wish to build for,
-# e.g "lib_static lib_shared exe module" as shown below
-install: module
-
-###################Include rules makefiles########################
-include ${ICP_BUILDSYSTEM_PATH}/build_files/rules.mk
-###################End of Rules inclusion#########################
-
-endif