port generic and ixp4xx kernel patches to 2.6.27 (compiles except for iptables, but...
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / files-2.6.27 / fs / yaffs2 / Makefile
diff --git a/target/linux/generic-2.6/files-2.6.27/fs/yaffs2/Makefile b/target/linux/generic-2.6/files-2.6.27/fs/yaffs2/Makefile
new file mode 100644 (file)
index 0000000..73f4658
--- /dev/null
@@ -0,0 +1,11 @@
+#
+# Makefile for the linux YAFFS filesystem routines.
+#
+
+obj-$(CONFIG_YAFFS_FS) += yaffs.o
+
+yaffs-y := yaffs_ecc.o yaffs_fs.o yaffs_guts.o yaffs_checkptrw.o
+yaffs-y += yaffs_packedtags2.o yaffs_nand.o yaffs_qsort.o
+yaffs-y += yaffs_tagscompat.o yaffs_tagsvalidity.o
+yaffs-y += yaffs_mtdif1.o yaffs_packedtags1.o
+yaffs-y += yaffs_mtdif.o yaffs_mtdif2.o