refresh generic 2.6.23 patches in upstream style
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.23 / 171-netfilter_tarpit.patch
index 847d47427edf899a3bba255c0d189cfe7062eae6..e74c9d9f214c0f5e727dca27ddd21243957c212d 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.23.17/net/netfilter/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/net/netfilter/Kconfig
-+++ linux-2.6.23.17/net/netfilter/Kconfig
-@@ -401,6 +401,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
+--- a/net/netfilter/Kconfig
++++ b/net/netfilter/Kconfig
+@@ -401,6 +401,23 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -26,11 +24,9 @@ Index: linux-2.6.23.17/net/netfilter/Kconfig
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
        depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.23.17/net/netfilter/Makefile
-===================================================================
---- linux-2.6.23.17.orig/net/netfilter/Makefile
-+++ linux-2.6.23.17/net/netfilter/Makefile
-@@ -47,6 +47,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG) 
+--- a/net/netfilter/Makefile
++++ b/net/netfilter/Makefile
+@@ -47,6 +47,7 @@
  obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK) += xt_SECMARK.o
@@ -38,10 +34,8 @@ Index: linux-2.6.23.17/net/netfilter/Makefile
  obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
-Index: linux-2.6.23.17/net/netfilter/xt_TARPIT.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.23.17/net/netfilter/xt_TARPIT.c
++++ b/net/netfilter/xt_TARPIT.c
 @@ -0,0 +1,280 @@
 +/*
 + * Kernel module to capture and hold incoming TCP connections using