[kernel] refresh generic 2.6.23 patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.23 / 640-mvswitch.patch
index 15c6e481ff5d73d2e539a4d503037ea0cc201f99..7b88397063d53782d0b52d9bbdd2226ea6c3277a 100644 (file)
@@ -1,8 +1,8 @@
-Index: linux-2.6.23.16/drivers/net/phy/Kconfig
+Index: linux-2.6.23.17/drivers/net/phy/Kconfig
 ===================================================================
---- linux-2.6.23.16.orig/drivers/net/phy/Kconfig       2008-04-20 07:31:20.000000000 +0200
-+++ linux-2.6.23.16/drivers/net/phy/Kconfig    2008-04-20 08:57:26.000000000 +0200
-@@ -65,6 +65,12 @@
+--- linux-2.6.23.17.orig/drivers/net/phy/Kconfig
++++ linux-2.6.23.17/drivers/net/phy/Kconfig
+@@ -65,6 +65,12 @@ config ADM6996_PHY
        ---help---
          Currently supports the ADM6996F switch
  
@@ -15,20 +15,20 @@ Index: linux-2.6.23.16/drivers/net/phy/Kconfig
  config FIXED_PHY
        tristate "Drivers for PHY emulation on fixed speed/link"
        ---help---
-Index: linux-2.6.23.16/drivers/net/phy/Makefile
+Index: linux-2.6.23.17/drivers/net/phy/Makefile
 ===================================================================
---- linux-2.6.23.16.orig/drivers/net/phy/Makefile      2008-04-20 07:31:20.000000000 +0200
-+++ linux-2.6.23.16/drivers/net/phy/Makefile   2008-04-20 07:31:34.000000000 +0200
-@@ -13,4 +13,5 @@
+--- linux-2.6.23.17.orig/drivers/net/phy/Makefile
++++ linux-2.6.23.17/drivers/net/phy/Makefile
+@@ -13,4 +13,5 @@ obj-$(CONFIG_VITESSE_PHY)    += vitesse.o
  obj-$(CONFIG_BROADCOM_PHY)    += broadcom.o
  obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
  obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
 +obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o
-Index: linux-2.6.23.16/drivers/net/phy/mdio_bus.c
+Index: linux-2.6.23.17/drivers/net/phy/mdio_bus.c
 ===================================================================
---- linux-2.6.23.16.orig/drivers/net/phy/mdio_bus.c    2008-04-20 04:40:31.000000000 +0200
-+++ linux-2.6.23.16/drivers/net/phy/mdio_bus.c 2008-04-20 07:34:08.000000000 +0200
+--- linux-2.6.23.17.orig/drivers/net/phy/mdio_bus.c
++++ linux-2.6.23.17/drivers/net/phy/mdio_bus.c
 @@ -35,6 +35,12 @@
  #include <asm/irq.h>
  #include <asm/uaccess.h>
@@ -42,7 +42,7 @@ Index: linux-2.6.23.16/drivers/net/phy/mdio_bus.c
  /**
   * mdiobus_register - bring up all the PHYs on a given bus and attach them to bus
   * @bus: target mii_bus
-@@ -85,6 +91,7 @@
+@@ -85,6 +91,7 @@ int mdiobus_register(struct mii_bus *bus
  
                        phydev->dev.parent = bus->dev;
                        phydev->dev.bus = &mdio_bus_type;