[kernel] refresh generic 2.6.24 patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 001-squashfs.patch
index 6d2cb28b98433dbcc4650ee755eb3450ef0ea594..fd3fb2b28a2633d3c6e91199114584fcb5b936a8 100644 (file)
@@ -1,8 +1,8 @@
-Index: linux-2.6.23/fs/Kconfig
+Index: linux-2.6.24.7/fs/Kconfig
 ===================================================================
---- linux-2.6.23.orig/fs/Kconfig       2007-10-10 13:52:12.000000000 +0800
-+++ linux-2.6.23/fs/Kconfig    2007-10-10 13:52:14.000000000 +0800
-@@ -1364,6 +1364,71 @@
+--- linux-2.6.24.7.orig/fs/Kconfig
++++ linux-2.6.24.7/fs/Kconfig
+@@ -1405,6 +1405,71 @@ config CRAMFS
  
          If unsure, say N.
  
@@ -74,11 +74,11 @@ Index: linux-2.6.23/fs/Kconfig
  config VXFS_FS
        tristate "FreeVxFS file system support (VERITAS VxFS(TM) compatible)"
        depends on BLOCK
-Index: linux-2.6.23/fs/Makefile
+Index: linux-2.6.24.7/fs/Makefile
 ===================================================================
---- linux-2.6.23.orig/fs/Makefile      2007-10-10 13:52:12.000000000 +0800
-+++ linux-2.6.23/fs/Makefile   2007-10-10 13:52:14.000000000 +0800
-@@ -72,6 +72,7 @@
+--- linux-2.6.24.7.orig/fs/Makefile
++++ linux-2.6.24.7/fs/Makefile
+@@ -72,6 +72,7 @@ obj-$(CONFIG_JBD)            += jbd/
  obj-$(CONFIG_JBD2)            += jbd2/
  obj-$(CONFIG_EXT2_FS)         += ext2/
  obj-$(CONFIG_CRAMFS)          += cramfs/
@@ -86,10 +86,10 @@ Index: linux-2.6.23/fs/Makefile
  obj-y                         += ramfs/
  obj-$(CONFIG_HUGETLBFS)               += hugetlbfs/
  obj-$(CONFIG_CODA_FS)         += coda/
-Index: linux-2.6.23/fs/squashfs/inode.c
+Index: linux-2.6.24.7/fs/squashfs/inode.c
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/fs/squashfs/inode.c   2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ linux-2.6.24.7/fs/squashfs/inode.c
 @@ -0,0 +1,2122 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -2213,10 +2213,10 @@ Index: linux-2.6.23/fs/squashfs/inode.c
 +MODULE_DESCRIPTION("squashfs, a compressed read-only filesystem");
 +MODULE_AUTHOR("Phillip Lougher <phillip@lougher.org.uk>");
 +MODULE_LICENSE("GPL");
-Index: linux-2.6.23/fs/squashfs/Makefile
+Index: linux-2.6.24.7/fs/squashfs/Makefile
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/fs/squashfs/Makefile  2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ linux-2.6.24.7/fs/squashfs/Makefile
 @@ -0,0 +1,7 @@
 +#
 +# Makefile for the linux squashfs routines.
@@ -2225,10 +2225,10 @@ Index: linux-2.6.23/fs/squashfs/Makefile
 +obj-$(CONFIG_SQUASHFS) += squashfs.o
 +squashfs-y += inode.o
 +squashfs-y += squashfs2_0.o
-Index: linux-2.6.23/fs/squashfs/squashfs2_0.c
+Index: linux-2.6.24.7/fs/squashfs/squashfs2_0.c
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/fs/squashfs/squashfs2_0.c     2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ linux-2.6.24.7/fs/squashfs/squashfs2_0.c
 @@ -0,0 +1,758 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -2988,10 +2988,10 @@ Index: linux-2.6.23/fs/squashfs/squashfs2_0.c
 +
 +      return 1;
 +}
-Index: linux-2.6.23/fs/squashfs/squashfs.h
+Index: linux-2.6.24.7/fs/squashfs/squashfs.h
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/fs/squashfs/squashfs.h        2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ linux-2.6.24.7/fs/squashfs/squashfs.h
 @@ -0,0 +1,86 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -3079,10 +3079,10 @@ Index: linux-2.6.23/fs/squashfs/squashfs.h
 +      return 0;
 +}
 +#endif
-Index: linux-2.6.23/include/linux/magic.h
+Index: linux-2.6.24.7/include/linux/magic.h
 ===================================================================
---- linux-2.6.23.orig/include/linux/magic.h    2007-10-10 13:52:12.000000000 +0800
-+++ linux-2.6.23/include/linux/magic.h 2007-10-10 13:52:14.000000000 +0800
+--- linux-2.6.24.7.orig/include/linux/magic.h
++++ linux-2.6.24.7/include/linux/magic.h
 @@ -35,6 +35,9 @@
  #define REISER2FS_SUPER_MAGIC_STRING  "ReIsEr2Fs"
  #define REISER2FS_JR_SUPER_MAGIC_STRING       "ReIsEr3Fs"
@@ -3092,11 +3092,11 @@ Index: linux-2.6.23/include/linux/magic.h
 +
  #define SMB_SUPER_MAGIC               0x517B
  #define USBDEVICE_SUPER_MAGIC 0x9fa2
-Index: linux-2.6.23/include/linux/squashfs_fs.h
+ #define CGROUP_SUPER_MAGIC    0x27e0eb
+Index: linux-2.6.24.7/include/linux/squashfs_fs.h
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/squashfs_fs.h   2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ linux-2.6.24.7/include/linux/squashfs_fs.h
 @@ -0,0 +1,911 @@
 +#ifndef SQUASHFS_FS
 +#define SQUASHFS_FS
@@ -4009,10 +4009,10 @@ Index: linux-2.6.23/include/linux/squashfs_fs.h
 +
 +#endif
 +#endif
-Index: linux-2.6.23/include/linux/squashfs_fs_i.h
+Index: linux-2.6.24.7/include/linux/squashfs_fs_i.h
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/squashfs_fs_i.h 2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ linux-2.6.24.7/include/linux/squashfs_fs_i.h
 @@ -0,0 +1,45 @@
 +#ifndef SQUASHFS_FS_I
 +#define SQUASHFS_FS_I
@@ -4059,10 +4059,10 @@ Index: linux-2.6.23/include/linux/squashfs_fs_i.h
 +      struct inode    vfs_inode;
 +};
 +#endif
-Index: linux-2.6.23/include/linux/squashfs_fs_sb.h
+Index: linux-2.6.24.7/include/linux/squashfs_fs_sb.h
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/squashfs_fs_sb.h        2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ linux-2.6.24.7/include/linux/squashfs_fs_sb.h
 @@ -0,0 +1,74 @@
 +#ifndef SQUASHFS_FS_SB
 +#define SQUASHFS_FS_SB
@@ -4138,10 +4138,10 @@ Index: linux-2.6.23/include/linux/squashfs_fs_sb.h
 +      int                     (*read_fragment_index_table)(struct super_block *s);
 +};
 +#endif
-Index: linux-2.6.23/init/do_mounts_rd.c
+Index: linux-2.6.24.7/init/do_mounts_rd.c
 ===================================================================
---- linux-2.6.23.orig/init/do_mounts_rd.c      2007-10-10 13:52:12.000000000 +0800
-+++ linux-2.6.23/init/do_mounts_rd.c   2007-10-10 13:52:14.000000000 +0800
+--- linux-2.6.24.7.orig/init/do_mounts_rd.c
++++ linux-2.6.24.7/init/do_mounts_rd.c
 @@ -5,6 +5,7 @@
  #include <linux/ext2_fs.h>
  #include <linux/romfs_fs.h>
@@ -4150,7 +4150,7 @@ Index: linux-2.6.23/init/do_mounts_rd.c
  #include <linux/initrd.h>
  #include <linux/string.h>
  
-@@ -39,6 +40,7 @@
+@@ -39,6 +40,7 @@ static int __init crd_load(int in_fd, in
   * numbers could not be found.
   *
   * We currently check for the following magic numbers:
@@ -4158,7 +4158,7 @@ Index: linux-2.6.23/init/do_mounts_rd.c
   *    minix
   *    ext2
   *    romfs
-@@ -53,6 +55,7 @@
+@@ -53,6 +55,7 @@ identify_ramdisk_image(int fd, int start
        struct ext2_super_block *ext2sb;
        struct romfs_super_block *romfsb;
        struct cramfs_super *cramfsb;
@@ -4166,7 +4166,7 @@ Index: linux-2.6.23/init/do_mounts_rd.c
        int nblocks = -1;
        unsigned char *buf;
  
-@@ -64,6 +67,7 @@
+@@ -64,6 +67,7 @@ identify_ramdisk_image(int fd, int start
        ext2sb = (struct ext2_super_block *) buf;
        romfsb = (struct romfs_super_block *) buf;
        cramfsb = (struct cramfs_super *) buf;
@@ -4174,7 +4174,7 @@ Index: linux-2.6.23/init/do_mounts_rd.c
        memset(buf, 0xe5, size);
  
        /*
-@@ -101,6 +105,15 @@
+@@ -101,6 +105,15 @@ identify_ramdisk_image(int fd, int start
                goto done;
        }