[kernel] refresh generic 2.6.24 patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 002-lzma_decompress.patch
index 9e75936f0f66b4bc6573fda3ff37246f7b71df3e..bb41b2df594366470063faaa9766be5c42fddad6 100644 (file)
@@ -1,7 +1,7 @@
-Index: linux-2.6.23/include/linux/LzmaDecode.h
+Index: linux-2.6.24.7/include/linux/LzmaDecode.h
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/LzmaDecode.h    2007-10-10 13:51:27.000000000 +0800
+--- /dev/null
++++ linux-2.6.24.7/include/linux/LzmaDecode.h
 @@ -0,0 +1,100 @@
 +/*
 +  LzmaDecode.h
@@ -103,10 +103,10 @@ Index: linux-2.6.23/include/linux/LzmaDecode.h
 +    UInt32 *outSizeProcessed);
 +
 +#endif
-Index: linux-2.6.23/lib/LzmaDecode.c
+Index: linux-2.6.24.7/lib/LzmaDecode.c
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/lib/LzmaDecode.c      2007-10-10 13:51:27.000000000 +0800
+--- /dev/null
++++ linux-2.6.24.7/lib/LzmaDecode.c
 @@ -0,0 +1,663 @@
 +/*
 +  LzmaDecode.c
@@ -771,12 +771,12 @@ Index: linux-2.6.23/lib/LzmaDecode.c
 +  *outSizeProcessed = nowPos;
 +  return LZMA_RESULT_OK;
 +}
-Index: linux-2.6.23/lib/Makefile
+Index: linux-2.6.24.7/lib/Makefile
 ===================================================================
---- linux-2.6.23.orig/lib/Makefile     2007-10-10 13:50:24.000000000 +0800
-+++ linux-2.6.23/lib/Makefile  2007-10-10 13:51:53.000000000 +0800
-@@ -13,7 +13,7 @@
- lib-y += kobject.o kref.o kobject_uevent.o klist.o
+--- linux-2.6.24.7.orig/lib/Makefile
++++ linux-2.6.24.7/lib/Makefile
+@@ -14,7 +14,7 @@ lib-$(CONFIG_SMP) += cpumask.o
+ lib-y += kobject.o kref.o klist.o
  
  obj-y += div64.o sort.o parser.o halfmd4.o debug_locks.o random32.o \
 -       bust_spinlocks.o hexdump.o kasprintf.o bitmap.o
@@ -784,7 +784,7 @@ Index: linux-2.6.23/lib/Makefile
  
  ifeq ($(CONFIG_DEBUG_KOBJECT),y)
  CFLAGS_kobject.o += -DDEBUG
-@@ -62,6 +62,7 @@
+@@ -64,6 +64,7 @@ obj-$(CONFIG_SMP) += percpu_counter.o
  obj-$(CONFIG_AUDIT_GENERIC) += audit.o
  
  obj-$(CONFIG_SWIOTLB) += swiotlb.o