[kernel] generic-2.6/2.6.24: refresh patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 130-netfilter_ipset.patch
index cee1cdc11098ad21875caa48e6676401fce0065e..52b272c17042982eff998c66bb8e0d1ae64b8046 100644 (file)
@@ -1,7 +1,7 @@
 --- a/include/linux/netfilter_ipv4/Kbuild
 +++ b/include/linux/netfilter_ipv4/Kbuild
-@@ -45,3 +45,14 @@
-
+@@ -45,3 +45,14 @@ header-y += ipt_ttl.h
  unifdef-y += ip_queue.h
  unifdef-y += ip_tables.h
 +
 +module_exit(ipt_SET_fini);
 --- a/net/ipv4/netfilter/Kconfig
 +++ b/net/ipv4/netfilter/Kconfig
-@@ -408,5 +408,122 @@
+@@ -408,5 +408,122 @@ config IP_NF_ARP_MANGLE
          Allows altering the ARP packet payload: source and destination
          hardware and network addresses.
  
  
 --- a/net/ipv4/netfilter/Makefile
 +++ b/net/ipv4/netfilter/Makefile
-@@ -49,6 +49,7 @@
+@@ -49,6 +49,7 @@ obj-$(CONFIG_IP_NF_MATCH_OWNER) += ipt_o
  obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
  obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos.o
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
  
  obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
  
-@@ -64,6 +65,18 @@
+@@ -64,6 +65,18 @@ obj-$(CONFIG_IP_NF_TARGET_SAME) += ipt_S
  obj-$(CONFIG_IP_NF_TARGET_TOS) += ipt_TOS.o
  obj-$(CONFIG_IP_NF_TARGET_TTL) += ipt_TTL.o
  obj-$(CONFIG_IP_NF_TARGET_ULOG) += ipt_ULOG.o