refresh generic 2.6.24 patches to match upstream style
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 140-netfilter_time.patch
index 0f8d4cd19d904fefcc97bc35b2a3d1929b9da788..b29c064346b215ff7ab51c15fe743070cbc30810 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_time.h
-===================================================================
 --- /dev/null
-+++ linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_time.h
++++ b/include/linux/netfilter_ipv4/ipt_time.h
 @@ -0,0 +1,18 @@
 +#ifndef __ipt_time_h_included__
 +#define __ipt_time_h_included__
@@ -21,10 +19,8 @@ Index: linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_time.h
 +
 +
 +#endif /* __ipt_time_h_included__ */
-Index: linux-2.6.24.7/net/ipv4/netfilter/ipt_time.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.24.7/net/ipv4/netfilter/ipt_time.c
++++ b/net/ipv4/netfilter/ipt_time.c
 @@ -0,0 +1,180 @@
 +/*
 +  This is a module which is used for time matching
@@ -206,11 +202,9 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/ipt_time.c
 +      r->tm_mon=i;
 +      r->tm_mday=work-__spm[i]+1;
 +}
-Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-@@ -78,6 +78,22 @@ config IP_NF_MATCH_TOS
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -78,6 +78,22 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -233,11 +227,9 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
  config IP_NF_MATCH_RECENT
        tristate "recent match support"
        depends on IP_NF_IPTABLES
-Index: linux-2.6.24.7/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.24.7/net/ipv4/netfilter/Makefile
-@@ -50,6 +50,7 @@ obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -50,6 +50,7 @@
  obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos.o
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
  obj-$(CONFIG_IP_NF_MATCH_SET) += ipt_set.o