update iptables to 1.4.0 (2.6 kernels only), refresh kernel patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 170-netfilter_chaostables.patch
diff --git a/target/linux/generic-2.6/patches-2.6.24/170-netfilter_chaostables.patch b/target/linux/generic-2.6/patches-2.6.24/170-netfilter_chaostables.patch
deleted file mode 100644 (file)
index b55aeb1..0000000
+++ /dev/null
@@ -1,965 +0,0 @@
-Index: linux-2.6.23/include/linux/netfilter/oot_conntrack.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/netfilter/oot_conntrack.h       2007-10-10 13:52:59.000000000 +0800
-@@ -0,0 +1,5 @@
-+#if defined(CONFIG_IP_NF_CONNTRACK) || defined(CONFIG_IP_NF_CONNTRACK_MODULE)
-+#     include <linux/netfilter_ipv4/ip_conntrack.h>
-+#else /* linux-2.6.20+ */
-+#     include <net/netfilter/nf_nat_rule.h>
-+#endif
-Index: linux-2.6.23/include/linux/netfilter/oot_trans.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/netfilter/oot_trans.h   2007-10-10 13:52:59.000000000 +0800
-@@ -0,0 +1,14 @@
-+/* Out of tree workarounds */
-+#include <linux/version.h>
-+#if LINUX_VERSION_CODE <= KERNEL_VERSION(2, 6, 18)
-+#     define HAVE_MATCHINFOSIZE 1
-+#     define HAVE_TARGUSERINFO 1
-+#     define HAVE_TARGINFOSIZE 1
-+#endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 20)
-+#     define nfmark mark
-+#endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 21)
-+#     define tcp_v4_check(tcph, tcph_sz, s, d, csp) \
-+              tcp_v4_check((tcph_sz), (s), (d), (csp))
-+#endif
-Index: linux-2.6.23/include/linux/netfilter/xt_CHAOS.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/netfilter/xt_CHAOS.h    2007-10-10 13:52:59.000000000 +0800
-@@ -0,0 +1,14 @@
-+#ifndef _LINUX_XT_CHAOS_H
-+#define _LINUX_XT_CHAOS_H 1
-+
-+enum xt_chaos_variant {
-+      XTCHAOS_NORMAL,
-+      XTCHAOS_TARPIT,
-+      XTCHAOS_DELUDE,
-+};
-+
-+struct xt_chaos_info {
-+      enum xt_chaos_variant variant;
-+};
-+
-+#endif /* _LINUX_XT_CHAOS_H */
-Index: linux-2.6.23/include/linux/netfilter/xt_portscan.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/netfilter/xt_portscan.h 2007-10-10 13:52:59.000000000 +0800
-@@ -0,0 +1,8 @@
-+#ifndef _LINUX_XT_PORTSCAN_H
-+#define _LINUX_XT_PORTSCAN_H 1
-+
-+struct xt_portscan_info {
-+      unsigned int match_stealth, match_syn, match_cn, match_gr;
-+};
-+
-+#endif /* _LINUX_XT_PORTSCAN_H */
-Index: linux-2.6.23/net/netfilter/find_match.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/net/netfilter/find_match.c    2007-10-10 13:52:59.000000000 +0800
-@@ -0,0 +1,39 @@
-+/*
-+    xt_request_find_match
-+    by Jan Engelhardt <jengelh [at] gmx de>, 2006 - 2007
-+
-+    Based upon linux-2.6.18.5/net/netfilter/x_tables.c:
-+    Copyright (C) 2006-2006 Harald Welte <laforge@netfilter.org>
-+    This program is free software; you can redistribute it and/or modify
-+    it under the terms of the GNU General Public License version 2 as
-+    published by the Free Software Foundation.
-+*/
-+#include <linux/err.h>
-+#include <linux/netfilter_arp.h>
-+#include <linux/socket.h>
-+#include <linux/netfilter/x_tables.h>
-+
-+/*
-+ * Yeah this code is sub-optimal, but the function is missing in
-+ * mainline so far. -jengelh
-+ */
-+static struct xt_match *xt_request_find_match_lo(int af, const char *name,
-+    u8 revision)
-+{
-+      static const char *const xt_prefix[] = {
-+              [AF_INET]  = "ip",
-+              [AF_INET6] = "ip6",
-+              [NF_ARP]   = "arp",
-+      };
-+      struct xt_match *match;
-+
-+      match = try_then_request_module(xt_find_match(af, name, revision),
-+              "%st_%s", xt_prefix[af], name);
-+      if(IS_ERR(match) || match == NULL)
-+              return NULL;
-+
-+      return match;
-+}
-+
-+/* In case it goes into mainline, let this out-of-tree package compile */
-+#define xt_request_find_match xt_request_find_match_lo
-Index: linux-2.6.23/net/netfilter/Kconfig
-===================================================================
---- linux-2.6.23.orig/net/netfilter/Kconfig    2007-10-10 04:31:38.000000000 +0800
-+++ linux-2.6.23/net/netfilter/Kconfig 2007-10-10 13:53:04.000000000 +0800
-@@ -265,6 +265,14 @@
- # alphabetically ordered list of targets
-+config NETFILTER_XT_TARGET_CHAOS
-+      tristate '"CHAOS" target support'
-+      depends on NETFILTER_XTABLES
-+      help
-+        This option adds a `CHAOS' target.
-+
-+        To compile it as a module, choose M here.  If unsure, say N.
-+
- config NETFILTER_XT_TARGET_CLASSIFY
-       tristate '"CLASSIFY" target support'
-       depends on NETFILTER_XTABLES
-@@ -292,6 +300,14 @@
-         <file:Documentation/kbuild/modules.txt>.  The module will be called
-         ipt_CONNMARK.ko.  If unsure, say `N'.
-+config NETFILTER_XT_TARGET_DELUDE
-+      tristate '"DELUDE" target support'
-+      depends on NETFILTER_XTABLES
-+      help
-+        This option adds a `DELUDE' target.
-+
-+        To compile it as a module, choose M here.  If unsure, say N.
-+
- config NETFILTER_XT_TARGET_DSCP
-       tristate '"DSCP" target support'
-       depends on NETFILTER_XTABLES
-@@ -556,6 +572,14 @@
-         To compile it as a module, choose M here.  If unsure, say N.
-+config NETFILTER_XT_MATCH_PORTSCAN
-+      tristate '"portscan" match support'
-+      depends on NETFILTER_XTABLES
-+      help
-+        This option adds a 'portscan' match support.
-+
-+        To compile it as a module, choose M here.  If unsure, say N.
-+
- config NETFILTER_XT_MATCH_MULTIPORT
-       tristate "Multiple port match support"
-       depends on NETFILTER_XTABLES
-Index: linux-2.6.23/net/netfilter/Makefile
-===================================================================
---- linux-2.6.23.orig/net/netfilter/Makefile   2007-10-10 04:31:38.000000000 +0800
-+++ linux-2.6.23/net/netfilter/Makefile        2007-10-10 13:52:59.000000000 +0800
-@@ -49,6 +49,8 @@
- obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK) += xt_SECMARK.o
- obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
- obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
-+obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
-+obj-$(CONFIG_NETFILTER_XT_TARGET_DELUDE) += xt_DELUDE.o
- # matches
- obj-$(CONFIG_NETFILTER_XT_MATCH_COMMENT) += xt_comment.o
-@@ -79,3 +81,4 @@
- obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
- obj-$(CONFIG_NETFILTER_XT_MATCH_TIME) += xt_time.o
- obj-$(CONFIG_NETFILTER_XT_MATCH_U32) += xt_u32.o
-+obj-$(CONFIG_NETFILTER_XT_MATCH_PORTSCAN) += xt_portscan.o
-Index: linux-2.6.23/net/netfilter/xt_CHAOS.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/net/netfilter/xt_CHAOS.c      2007-10-10 13:52:59.000000000 +0800
-@@ -0,0 +1,205 @@
-+/*
-+      CHAOS target for netfilter
-+
-+      Copyright © Jan Engelhardt <jengelh [at] gmx de>, 2006 - 2007
-+      This program is free software; you can redistribute it and/or modify
-+      it under the terms of the GNU General Public License version 2 as
-+      published by the Free Software Foundation.
-+*/
-+#include <linux/icmp.h>
-+#include <linux/in.h>
-+#include <linux/ip.h>
-+#include <linux/module.h>
-+#include <linux/skbuff.h>
-+#include <linux/stat.h>
-+#include <linux/netfilter/x_tables.h>
-+#include <linux/netfilter/xt_tcpudp.h>
-+#include <linux/netfilter_ipv4/ipt_REJECT.h>
-+#include <net/ip.h>
-+#include <linux/netfilter/xt_CHAOS.h>
-+#include "find_match.c"
-+#include <linux/netfilter/oot_trans.h>
-+#define PFX KBUILD_MODNAME ": "
-+
-+/* Module parameters */
-+static unsigned int reject_percentage = ~0U * .01;
-+static unsigned int delude_percentage = ~0U * .0101;
-+module_param(reject_percentage, uint, S_IRUGO | S_IWUSR);
-+module_param(delude_percentage, uint, S_IRUGO | S_IWUSR);
-+
-+/* References to other matches/targets */
-+static struct xt_match *xm_tcp;
-+static struct xt_target *xt_delude, *xt_reject, *xt_tarpit;
-+
-+static int have_delude, have_tarpit;
-+
-+/* Static data for other matches/targets */
-+static const struct ipt_reject_info reject_params = {
-+      .with = ICMP_HOST_UNREACH,
-+};
-+
-+static const struct xt_tcp tcp_params = {
-+      .spts = {0, ~0},
-+      .dpts = {0, ~0},
-+};
-+
-+/* CHAOS functions */
-+static void xt_chaos_total(const struct xt_chaos_info *info,
-+    struct sk_buff *skb, const struct net_device *in,
-+    const struct net_device *out, unsigned int hooknum)
-+{
-+      const int protoff = ip_hdrlen(skb);
-+      const int offset  = ntohs(ip_hdr(skb)->frag_off) & IP_OFFSET;
-+      const struct xt_target *destiny;
-+      bool hotdrop = false;
-+      int ret;
-+
-+      ret = xm_tcp->match(skb, in, out, xm_tcp, &tcp_params,
-+                          offset, protoff, &hotdrop);
-+      if(!ret || hotdrop || (unsigned int)net_random() > delude_percentage)
-+              return;
-+
-+      destiny = (info->variant == XTCHAOS_TARPIT) ? xt_tarpit : xt_delude;
-+#ifdef HAVE_TARGUSERINFO
-+      destiny->target(skb, in, out, hooknum, destiny, NULL, NULL);
-+#else
-+      destiny->target(skb, in, out, hooknum, destiny, NULL);
-+#endif
-+      return;
-+}
-+
-+static unsigned int xt_chaos_target(struct sk_buff *skb,
-+    const struct net_device *in, const struct net_device *out,
-+    unsigned int hooknum, const struct xt_target *target, const void *targinfo
-+#ifdef HAVE_TARGUSERINFO
-+    ,
-+    void *userinfo
-+#endif
-+    )
-+{
-+      /* Equivalent to:
-+       * -A chaos -m statistic --mode random --probability \
-+       *         $reject_percentage -j REJECT --reject-with host-unreach;
-+       * -A chaos -p tcp -m statistic --mode random --probability \
-+       *         $delude_percentage -j DELUDE;
-+       * -A chaos -j DROP;
-+       */
-+      const struct xt_chaos_info *info = targinfo;
-+
-+      if((unsigned int)net_random() <= reject_percentage)
-+#ifdef HAVE_TARGUSERINFO
-+              return xt_reject->target(skb, in, out, hooknum, target,
-+                     &reject_params, userinfo);
-+#else
-+              return xt_reject->target(skb, in, out, hooknum, target,
-+                     &reject_params);
-+#endif
-+
-+      /* TARPIT/DELUDE may not be called from the OUTPUT chain */
-+      if(ip_hdr(skb)->protocol == IPPROTO_TCP &&
-+        info->variant != XTCHAOS_NORMAL && hooknum != NF_IP_LOCAL_OUT)
-+              xt_chaos_total(info, skb, in, out, hooknum);
-+
-+      return NF_DROP;
-+}
-+
-+static bool xt_chaos_checkentry(const char *tablename, const void *entry,
-+    const struct xt_target *target, void *targinfo,
-+#ifdef HAVE_TARGINFOSIZE
-+    unsigned int targinfosize,
-+#endif
-+    unsigned int hook_mask)
-+{
-+      const struct xt_chaos_info *info = targinfo;
-+      if(info->variant == XTCHAOS_DELUDE && !have_delude) {
-+              printk(KERN_WARNING PFX "Error: Cannot use --delude when "
-+                     "DELUDE module not available\n");
-+              return false;
-+      }
-+      if(info->variant == XTCHAOS_TARPIT && !have_tarpit) {
-+              printk(KERN_WARNING PFX "Error: Cannot use --tarpit when "
-+                     "TARPIT module not available\n");
-+              return false;
-+      }
-+      return true;
-+}
-+
-+static struct xt_target xt_chaos_info = {
-+      .name       = "CHAOS",
-+      .target     = xt_chaos_target,
-+      .checkentry = xt_chaos_checkentry,
-+      .table      = "filter",
-+      .targetsize = sizeof(struct xt_chaos_info),
-+      .hooks      = (1 << NF_IP_LOCAL_IN) | (1 << NF_IP_FORWARD) |
-+                    (1 << NF_IP_LOCAL_OUT),
-+      .family     = AF_INET,
-+      .me         = THIS_MODULE,
-+};
-+
-+static int __init xt_chaos_init(void)
-+{
-+      int ret = -EINVAL;
-+
-+      xm_tcp = xt_request_find_match(AF_INET, "tcp", 0);
-+      if(xm_tcp == NULL) {
-+              printk(KERN_WARNING PFX "Error: Could not find or load "
-+                     "\"tcp\" match\n");
-+              return -EINVAL;
-+      }
-+
-+      xt_reject = xt_request_find_target(AF_INET, "REJECT", 0);
-+      if(xt_reject == NULL) {
-+              printk(KERN_WARNING PFX "Error: Could not find or load "
-+                     "\"REJECT\" target\n");
-+              goto out2;
-+      }
-+
-+      xt_tarpit   = xt_request_find_target(AF_INET, "TARPIT", 0);
-+      have_tarpit = xt_tarpit != NULL;
-+      if(!have_tarpit)
-+              printk(KERN_WARNING PFX "Warning: Could not find or load "
-+                     "\"TARPIT\" target\n");
-+
-+      xt_delude   = xt_request_find_target(AF_INET, "DELUDE", 0);
-+      have_delude = xt_delude != NULL;
-+      if(!have_delude)
-+              printk(KERN_WARNING PFX "Warning: Could not find or load "
-+                     "\"DELUDE\" target\n");
-+
-+      if((ret = xt_register_target(&xt_chaos_info)) != 0) {
-+              printk(KERN_WARNING PFX "xt_register_target returned "
-+                     "error %d\n", ret);
-+              goto out3;
-+      }
-+
-+      return 0;
-+
-+ out3:
-+      if(have_delude)
-+              module_put(xt_delude->me);
-+      if(have_tarpit)
-+              module_put(xt_tarpit->me);
-+      module_put(xt_reject->me);
-+ out2:
-+      module_put(xm_tcp->me);
-+      return ret;
-+}
-+
-+static void __exit xt_chaos_exit(void)
-+{
-+      xt_unregister_target(&xt_chaos_info);
-+      module_put(xm_tcp->me);
-+      module_put(xt_reject->me);
-+      if(have_delude)
-+              module_put(xt_delude->me);
-+      if(have_tarpit)
-+              module_put(xt_tarpit->me);
-+      return;
-+}
-+
-+module_init(xt_chaos_init);
-+module_exit(xt_chaos_exit);
-+MODULE_AUTHOR("Jan Engelhardt <jengelh@gmx.de>");
-+MODULE_DESCRIPTION("netfilter CHAOS target");
-+MODULE_LICENSE("GPL");
-+MODULE_ALIAS("ipt_CHAOS");
-Index: linux-2.6.23/net/netfilter/xt_DELUDE.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/net/netfilter/xt_DELUDE.c     2007-10-10 13:52:59.000000000 +0800
-@@ -0,0 +1,288 @@
-+/*
-+      DELUDE target
-+      Copyright © Jan Engelhardt <jengelh [at] gmx de>, 2007
-+
-+      Based upon linux-2.6.18.5/net/ipv4/netfilter/ipt_REJECT.c:
-+      (C) 1999-2001 Paul `Rusty' Russell
-+      (C) 2002-2004 Netfilter Core Team <coreteam@netfilter.org>
-+
-+      xt_DELUDE acts like REJECT, but does reply with SYN-ACK on SYN.
-+
-+      This program is free software; you can redistribute it and/or modify
-+      it under the terms of the GNU General Public License version 2 as
-+      published by the Free Software Foundation.
-+*/
-+#include <linux/module.h>
-+#include <linux/skbuff.h>
-+#include <linux/ip.h>
-+#include <linux/random.h>
-+#include <linux/tcp.h>
-+#include <linux/udp.h>
-+#include <linux/icmp.h>
-+#include <net/icmp.h>
-+#include <net/ip.h>
-+#include <net/tcp.h>
-+#include <net/route.h>
-+#include <net/dst.h>
-+#include <linux/netfilter_ipv4/ip_tables.h>
-+#ifdef CONFIG_BRIDGE_NETFILTER
-+#     include <linux/netfilter_bridge.h>
-+#endif
-+#include <linux/netfilter/oot_trans.h>
-+#define PFX KBUILD_MODNAME ": "
-+
-+static inline struct rtable *route_reverse(struct sk_buff *skb,
-+                                         struct tcphdr *tcph, int hook)
-+{
-+      struct iphdr *iph = ip_hdr(skb);
-+      struct dst_entry *odst;
-+      struct flowi fl = {};
-+      struct rtable *rt;
-+
-+      /* We don't require ip forwarding to be enabled to be able to
-+       * send a RST reply for bridged traffic. */
-+      if (hook != NF_IP_FORWARD
-+#ifdef CONFIG_BRIDGE_NETFILTER
-+          || (skb->nf_bridge && skb->nf_bridge->mask & BRNF_BRIDGED)
-+#endif
-+         ) {
-+              fl.nl_u.ip4_u.daddr = iph->saddr;
-+              if (hook == NF_IP_LOCAL_IN)
-+                      fl.nl_u.ip4_u.saddr = iph->daddr;
-+              fl.nl_u.ip4_u.tos = RT_TOS(iph->tos);
-+
-+              if (ip_route_output_key(&rt, &fl) != 0)
-+                      return NULL;
-+      } else {
-+              /* non-local src, find valid iif to satisfy
-+               * rp-filter when calling ip_route_input. */
-+              fl.nl_u.ip4_u.daddr = iph->daddr;
-+              if (ip_route_output_key(&rt, &fl) != 0)
-+                      return NULL;
-+
-+              odst = skb->dst;
-+              if (ip_route_input(skb, iph->saddr, iph->daddr,
-+                                 RT_TOS(iph->tos), rt->u.dst.dev) != 0) {
-+                      dst_release(&rt->u.dst);
-+                      return NULL;
-+              }
-+              dst_release(&rt->u.dst);
-+              rt = (struct rtable *)skb->dst;
-+              skb->dst = odst;
-+
-+              fl.nl_u.ip4_u.daddr = iph->saddr;
-+              fl.nl_u.ip4_u.saddr = iph->daddr;
-+              fl.nl_u.ip4_u.tos = RT_TOS(iph->tos);
-+      }
-+
-+      if (rt->u.dst.error) {
-+              dst_release(&rt->u.dst);
-+              return NULL;
-+      }
-+
-+      fl.proto = IPPROTO_TCP;
-+      fl.fl_ip_sport = tcph->dest;
-+      fl.fl_ip_dport = tcph->source;
-+
-+      xfrm_lookup((struct dst_entry **)&rt, &fl, NULL, 0);
-+
-+      return rt;
-+}
-+
-+static void send_reset(struct sk_buff *oldskb, int hook)
-+{
-+      struct sk_buff *nskb;
-+      struct iphdr *iph = ip_hdr(oldskb);
-+      struct tcphdr _otcph, *oth, *tcph;
-+      __be16 tmp_port;
-+      __be32 tmp_addr;
-+      int needs_ack;
-+      unsigned int addr_type;
-+
-+      /* IP header checks: fragment. */
-+      if (iph->frag_off & htons(IP_OFFSET))
-+              return;
-+
-+      oth = skb_header_pointer(oldskb, ip_hdrlen(oldskb),
-+                               sizeof(_otcph), &_otcph);
-+      if (oth == NULL)
-+              return;
-+
-+      /* No RST for RST. */
-+      if (oth->rst)
-+              return;
-+
-+      /* Check checksum */
-+      if (nf_ip_checksum(oldskb, hook, ip_hdrlen(oldskb), IPPROTO_TCP))
-+              return;
-+
-+      /* We need a linear, writeable skb.  We also need to expand
-+         headroom in case hh_len of incoming interface < hh_len of
-+         outgoing interface */
-+      nskb = skb_copy_expand(oldskb, LL_MAX_HEADER, skb_tailroom(oldskb),
-+                             GFP_ATOMIC);
-+      if (!nskb)
-+              return;
-+
-+      /* This packet will not be the same as the other: clear nf fields */
-+      nf_reset(nskb);
-+      nskb->nfmark = 0;
-+      skb_init_secmark(nskb);
-+
-+      skb_shinfo(nskb)->gso_size = 0;
-+      skb_shinfo(nskb)->gso_segs = 0;
-+      skb_shinfo(nskb)->gso_type = 0;
-+
-+      tcph = tcp_hdr(nskb);
-+
-+      /* Swap source and dest */
-+      tmp_addr = ip_hdr(nskb)->saddr;
-+      ip_hdr(nskb)->saddr = ip_hdr(nskb)->daddr;
-+      ip_hdr(nskb)->daddr = tmp_addr;
-+      tmp_port = tcph->source;
-+      tcph->source = tcph->dest;
-+      tcph->dest = tmp_port;
-+
-+      /* Truncate to length (no data) */
-+      tcph->doff = sizeof(struct tcphdr)/4;
-+      skb_trim(nskb, ip_hdrlen(nskb) + sizeof(struct tcphdr));
-+      ip_hdr(nskb)->tot_len = htons(nskb->len);
-+
-+      if(oth->syn && !oth->ack && !oth->rst && !oth->fin) {
-+              /* DELUDE essential part */
-+              tcph->ack_seq = htonl(ntohl(oth->seq) + oth->syn + oth->fin +
-+                              oldskb->len - ip_hdrlen(oldskb) -
-+                              (oth->doff << 2));
-+              tcph->seq     = htonl(secure_tcp_sequence_number(
-+                              ip_hdr(nskb)->saddr, ip_hdr(nskb)->daddr,
-+                              tcph->source, tcph->dest));
-+              tcph->ack     = 1;
-+      } else {
-+              if(!tcph->ack) {
-+                      needs_ack = 1;
-+                      tcph->ack_seq = htonl(ntohl(oth->seq) + oth->syn + oth->fin
-+                                            + oldskb->len - ip_hdrlen(oldskb)
-+                                            - (oth->doff<<2));
-+                      tcph->seq = 0;
-+              } else {
-+                      needs_ack = 0;
-+                      tcph->seq = oth->ack_seq;
-+                      tcph->ack_seq = 0;
-+              }
-+
-+              /* Reset flags */
-+              ((u_int8_t *)tcph)[13] = 0;
-+              tcph->rst = 1;
-+              tcph->ack = needs_ack;
-+      }
-+
-+
-+      tcph->window = 0;
-+      tcph->urg_ptr = 0;
-+
-+      /* Adjust TCP checksum */
-+      tcph->check = 0;
-+      tcph->check = tcp_v4_check(tcph, sizeof(struct tcphdr),
-+                                 ip_hdr(nskb)->saddr,
-+                                 ip_hdr(nskb)->daddr,
-+                                 csum_partial((char *)tcph,
-+                                              sizeof(struct tcphdr), 0));
-+
-+      /* Set DF, id = 0 */
-+      ip_hdr(nskb)->frag_off = htons(IP_DF);
-+      ip_hdr(nskb)->id = 0;
-+
-+      addr_type = RTN_UNSPEC;
-+      if (hook != NF_IP_FORWARD
-+#ifdef CONFIG_BRIDGE_NETFILTER
-+          || (nskb->nf_bridge && nskb->nf_bridge->mask & BRNF_BRIDGED)
-+#endif
-+         )
-+              addr_type = RTN_LOCAL;
-+
-+      if (ip_route_me_harder(nskb, addr_type))
-+              goto free_nskb;
-+
-+      nskb->ip_summed = CHECKSUM_NONE;
-+
-+      /* Adjust IP TTL */
-+      ip_hdr(nskb)->ttl = dst_metric(nskb->dst, RTAX_HOPLIMIT);
-+
-+      /* Adjust IP checksum */
-+      ip_hdr(nskb)->check = 0;
-+      ip_hdr(nskb)->check = ip_fast_csum((unsigned char *)ip_hdr(nskb),
-+                                         ip_hdr(nskb)->ihl);
-+
-+      /* "Never happens" */
-+      if (nskb->len > dst_mtu(nskb->dst))
-+              goto free_nskb;
-+
-+      nf_ct_attach(nskb, oldskb);
-+
-+      NF_HOOK(PF_INET, NF_IP_LOCAL_OUT, nskb, NULL, nskb->dst->dev,
-+              dst_output);
-+      return;
-+
-+ free_nskb:
-+      kfree_skb(nskb);
-+}
-+
-+static unsigned int xt_delude_target(struct sk_buff *skb,
-+    const struct net_device *in, const struct net_device *out,
-+    unsigned int hooknum, const struct xt_target *target, const void *targinfo
-+#ifdef HAVE_TARGUSERINFO
-+    ,
-+    void *userinfo
-+#endif
-+    )
-+{
-+      /* WARNING: This code causes reentry within iptables.
-+         This means that the iptables jump stack is now crap.  We
-+         must return an absolute verdict. --RR */
-+      send_reset(skb, hooknum);
-+      return NF_DROP;
-+}
-+
-+static bool xt_delude_check(const char *tablename, const void *e_void,
-+    const struct xt_target *target, void *targinfo,
-+#ifdef HAVE_TARGINFOSIZE
-+    unsigned int targinfosize,
-+#endif
-+    unsigned int hook_mask)
-+{
-+      if(hook_mask & ~((1 << NF_IP_LOCAL_IN) | (1 << NF_IP_FORWARD))) {
-+              printk(KERN_WARNING PFX "DELUDE may not be used in chains "
-+                     "other than INPUT and FORWARD\n");
-+              return false;
-+      }
-+      return true;
-+}
-+
-+static struct xt_target xt_delude_info = {
-+      .name       = "DELUDE",
-+      .target     = xt_delude_target,
-+      .checkentry = xt_delude_check,
-+      .table      = "filter",
-+      .hooks      = (1 << NF_IP_LOCAL_IN) | (1 << NF_IP_FORWARD) |
-+                    (1 << NF_IP_LOCAL_OUT),
-+      .proto      = IPPROTO_TCP,
-+      .family     = AF_INET,
-+      .me         = THIS_MODULE,
-+};
-+
-+static int __init xt_delude_init(void)
-+{
-+      return xt_register_target(&xt_delude_info);
-+}
-+
-+static void __exit xt_delude_exit(void)
-+{
-+      xt_unregister_target(&xt_delude_info);
-+}
-+
-+module_init(xt_delude_init);
-+module_exit(xt_delude_exit);
-+MODULE_AUTHOR("Jan Engelhardt <jengelh@gmx.de>");
-+MODULE_DESCRIPTION("netfilter DELUDE target");
-+MODULE_LICENSE("GPL");
-+MODULE_ALIAS("ipt_DELUDE");
-Index: linux-2.6.23/net/netfilter/xt_portscan.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/net/netfilter/xt_portscan.c   2007-10-10 13:52:59.000000000 +0800
-@@ -0,0 +1,272 @@
-+/*
-+      portscan match for netfilter
-+
-+      Written by Jan Engelhardt, 2006 - 2007
-+      This program is free software; you can redistribute it and/or modify
-+      it under the terms of the GNU General Public License version 2 as
-+      published by the Free Software Foundation.
-+*/
-+#include <linux/in.h>
-+#include <linux/ip.h>
-+#include <linux/module.h>
-+#include <linux/moduleparam.h>
-+#include <linux/skbuff.h>
-+#include <linux/stat.h>
-+#include <linux/tcp.h>
-+#include <linux/types.h>
-+#include <linux/version.h>
-+#include <linux/netfilter/x_tables.h>
-+#include <linux/netfilter/xt_tcpudp.h>
-+#include <linux/netfilter/oot_conntrack.h>
-+#include <linux/netfilter/xt_portscan.h>
-+#include <linux/netfilter/oot_trans.h>
-+#define PFX KBUILD_MODNAME ": "
-+
-+enum {
-+      TCP_FLAGS_ALL3 = TCP_FLAG_FIN | TCP_FLAG_RST | TCP_FLAG_SYN,
-+      TCP_FLAGS_ALL4 = TCP_FLAGS_ALL3 | TCP_FLAG_ACK,
-+      TCP_FLAGS_ALL6 = TCP_FLAGS_ALL4 | TCP_FLAG_PSH | TCP_FLAG_URG,
-+};
-+
-+/* Module parameters */
-+static unsigned int
-+      connmark_mask = ~0,
-+      packet_mask   = ~0,
-+      mark_seen     = 0x9,
-+      mark_synrcv   = 0x1,
-+      mark_closed   = 0x2,
-+      mark_synscan  = 0x3,
-+      mark_estab1   = 0x4,
-+      mark_estab2   = 0x5,
-+      mark_cnscan   = 0x6,
-+      mark_grscan   = 0x7,
-+      mark_valid    = 0x8;
-+
-+module_param(connmark_mask, uint, S_IRUGO | S_IWUSR);
-+module_param(packet_mask,   uint, S_IRUGO | S_IWUSR);
-+module_param(mark_seen,     uint, S_IRUGO | S_IWUSR);
-+module_param(mark_synrcv,   uint, S_IRUGO | S_IWUSR);
-+module_param(mark_closed,   uint, S_IRUGO | S_IWUSR);
-+module_param(mark_synscan,  uint, S_IRUGO | S_IWUSR);
-+module_param(mark_estab1,   uint, S_IRUGO | S_IWUSR);
-+module_param(mark_estab2,   uint, S_IRUGO | S_IWUSR);
-+module_param(mark_cnscan,   uint, S_IRUGO | S_IWUSR);
-+module_param(mark_grscan,   uint, S_IRUGO | S_IWUSR);
-+module_param(mark_valid,    uint, S_IRUGO | S_IWUSR);
-+MODULE_PARM_DESC(connmark_mask, "only set specified bits in connection mark");
-+MODULE_PARM_DESC(packet_mask,   "only set specified bits in packet mark");
-+MODULE_PARM_DESC(mark_seen,     "nfmark value for packet-seen state");
-+MODULE_PARM_DESC(mark_synrcv,   "connmark value for SYN Received state");
-+MODULE_PARM_DESC(mark_closed,   "connmark value for closed state");
-+MODULE_PARM_DESC(mark_synscan,  "connmark value for SYN Scan state");
-+MODULE_PARM_DESC(mark_estab1,   "connmark value for Established-1 state");
-+MODULE_PARM_DESC(mark_estab2,   "connmark value for Established-2 state");
-+MODULE_PARM_DESC(mark_cnscan,   "connmark value for Connect Scan state");
-+MODULE_PARM_DESC(mark_grscan,   "connmark value for Grab Scan state");
-+MODULE_PARM_DESC(mark_valid,    "connmark value for Valid state");
-+
-+/* TCP flag functions */
-+static inline int tflg_ack4(const struct tcphdr *th)
-+{
-+      return (tcp_flag_word(th) & TCP_FLAGS_ALL4) == TCP_FLAG_ACK;
-+}
-+
-+static inline int tflg_ack6(const struct tcphdr *th)
-+{
-+      return (tcp_flag_word(th) & TCP_FLAGS_ALL6) == TCP_FLAG_ACK;
-+}
-+
-+static inline int tflg_fin(const struct tcphdr *th)
-+{
-+      return (tcp_flag_word(th) & TCP_FLAGS_ALL3) == TCP_FLAG_FIN;
-+}
-+
-+static inline int tflg_rst(const struct tcphdr *th)
-+{
-+      return (tcp_flag_word(th) & TCP_FLAGS_ALL3) == TCP_FLAG_RST;
-+}
-+
-+static inline int tflg_rstack(const struct tcphdr *th)
-+{
-+      return (tcp_flag_word(th) & TCP_FLAGS_ALL4) ==
-+             (TCP_FLAG_ACK | TCP_FLAG_RST);
-+}
-+
-+static inline int tflg_syn(const struct tcphdr *th)
-+{
-+      return (tcp_flag_word(th) & TCP_FLAGS_ALL4) == TCP_FLAG_SYN;
-+}
-+
-+static inline int tflg_synack(const struct tcphdr *th)
-+{
-+      return (tcp_flag_word(th) & TCP_FLAGS_ALL4) ==
-+             (TCP_FLAG_SYN | TCP_FLAG_ACK);
-+}
-+
-+/* portscan functions */
-+static inline int xt_portscan_stealth(const struct tcphdr *th)
-+{
-+      /*
-+       * "Connection refused" replies to our own probes must not be matched.
-+       */
-+      if(tflg_rstack(th))
-+              return 0;
-+
-+      if(tflg_rst(th) && printk_ratelimit()) {
-+              printk(KERN_WARNING PFX "Warning: Pure RST received\n");
-+              return 0;
-+      }
-+
-+      /*
-+       * -p tcp ! --syn -m conntrack --ctstate INVALID: Looking for non-start
-+       * packets that are not associated with any connection -- this will
-+       * match most scan types (NULL, XMAS, FIN) and ridiculous flag
-+       * combinations (SYN-RST, SYN-FIN, SYN-FIN-RST, FIN-RST, etc.).
-+       */
-+      return !tflg_syn(th);
-+}
-+
-+static inline int xt_portscan_full(int mark, enum ip_conntrack_info ctstate,
-+    int loopback, const struct tcphdr *tcph, int payload_len)
-+{
-+      if(mark == mark_estab2) {
-+              /*
-+               * -m connmark --mark $ESTAB2
-+               */
-+              if(tflg_ack4(tcph) && payload_len == 0)
-+                      return mark; /* keep mark */
-+              else if(tflg_rst(tcph) || tflg_fin(tcph))
-+                      return mark_grscan;
-+              else
-+                      return mark_valid;
-+      } else if(mark == mark_estab1) {
-+              /*
-+               * -m connmark --mark $ESTAB1
-+               */
-+              if(tflg_rst(tcph) || tflg_fin(tcph))
-+                      return mark_cnscan;
-+              else if(!loopback && tflg_ack4(tcph) && payload_len == 0)
-+                      return mark_estab2;
-+              else
-+                      return mark_valid;
-+      } else if(mark == mark_synrcv) {
-+              /*
-+               * -m connmark --mark $SYN
-+               */
-+              if(loopback && tflg_synack(tcph))
-+                      return mark; /* keep mark */
-+              else if(loopback && tflg_rstack(tcph))
-+                      return mark_closed;
-+              else if(tflg_ack6(tcph))
-+                      return mark_estab1;
-+              else
-+                      return mark_synscan;
-+      } else if(ctstate == IP_CT_NEW && tflg_syn(tcph)) {
-+              /*
-+               * -p tcp --syn --ctstate NEW
-+               */
-+              return mark_synrcv;
-+      }
-+      return mark;
-+}
-+
-+static bool xt_portscan_match(const struct sk_buff *skb,
-+    const struct net_device *in, const struct net_device *out,
-+    const struct xt_match *match, const void *matchinfo, int offset,
-+    unsigned int protoff, bool *hotdrop)
-+{
-+      const struct xt_portscan_info *info = matchinfo;
-+      enum ip_conntrack_info ctstate;
-+      struct nf_conn *ctdata;
-+      const struct tcphdr *tcph;
-+      struct tcphdr tcph_buf;
-+
-+      tcph = skb_header_pointer(skb, protoff, sizeof(tcph_buf), &tcph_buf);
-+      if(tcph == NULL)
-+              return false;
-+
-+      /* Check for invalid packets: -m conntrack --ctstate INVALID */
-+      if((ctdata = nf_ct_get(skb, &ctstate)) == NULL) {
-+              if(info->match_stealth)
-+                      return xt_portscan_stealth(tcph);
-+              /*
-+               * If @ctdata is NULL, we cannot match the other scan
-+               * types, return.
-+               */
-+              return false;
-+      }
-+
-+      /*
-+       * If -m portscan was previously applied to this packet, the rules we
-+       * simulate must not be run through again. And for speedup, do not call
-+       * it either when the connection is already VALID.
-+       */
-+      if((ctdata->mark & connmark_mask) == mark_valid ||
-+        (skb->nfmark & packet_mask) != mark_seen)
-+      {
-+              unsigned int n;
-+              n = xt_portscan_full(ctdata->mark & connmark_mask, ctstate,
-+                  (in->flags && IFF_LOOPBACK) == IFF_LOOPBACK, tcph,
-+                  skb->len - protoff - 4 * tcph->doff);
-+
-+              ctdata->mark = (ctdata->mark & ~connmark_mask) | n;
-+              ((struct sk_buff *)skb)->nfmark =
-+                      (skb->nfmark & ~packet_mask) | mark_seen;
-+      }
-+
-+      return (info->match_syn && ctdata->mark == mark_synscan) ||
-+             (info->match_cn && ctdata->mark == mark_cnscan) ||
-+             (info->match_gr && ctdata->mark == mark_grscan);
-+}
-+
-+static bool xt_portscan_checkentry(const char *tablename, const void *entry,
-+    const struct xt_match *match, void *matchinfo,
-+#ifdef HAVE_MATCHINFOSIZE
-+    unsigned int matchinfosize,
-+#endif
-+    unsigned int hook_mask)
-+{
-+      const struct xt_portscan_info *info = matchinfo;
-+#ifdef HAVE_MATCHINFOSIZE
-+      if(matchinfosize != XT_ALIGN(sizeof(struct xt_portscan_info))) {
-+              printk(KERN_WARNING PFX "matchinfosize %u != %Zu\n",
-+                     matchinfosize,
-+                     XT_ALIGN(sizeof(struct xt_portscan_info)));
-+              return false;
-+      }
-+#endif
-+      if((info->match_stealth & ~1) || (info->match_syn & ~1) ||
-+        (info->match_cn & ~1) || (info->match_gr & ~1)) {
-+              printk(KERN_WARNING PFX "Invalid flags\n");
-+              return false;
-+      }
-+      return true;
-+}
-+
-+static struct xt_match xt_portscan = {
-+      .name       = "portscan",
-+      .match      = xt_portscan_match,
-+      .checkentry = xt_portscan_checkentry,
-+      .matchsize  = sizeof(struct xt_portscan_info),
-+      .proto      = IPPROTO_TCP,
-+      .family     = AF_INET,
-+      .me         = THIS_MODULE,
-+};
-+
-+static int __init xt_portscan_init(void)
-+{
-+      return xt_register_match(&xt_portscan);
-+}
-+
-+static void __exit xt_portscan_exit(void)
-+{
-+      xt_unregister_match(&xt_portscan);
-+      return;
-+}
-+
-+module_init(xt_portscan_init);
-+module_exit(xt_portscan_exit);
-+MODULE_AUTHOR("Jan Engelhardt <jengelh@gmx.de>");
-+MODULE_DESCRIPTION("netfilter portscan match module");
-+MODULE_LICENSE("GPL");
-+MODULE_ALIAS("ipt_portscan");
-Index: linux-2.6.23/drivers/char/random.c
-===================================================================
---- linux-2.6.23.orig/drivers/char/random.c    2007-10-10 04:31:38.000000000 +0800
-+++ linux-2.6.23/drivers/char/random.c 2007-10-10 13:52:59.000000000 +0800
-@@ -1564,6 +1564,8 @@
-       return seq;
- }
-+EXPORT_SYMBOL(secure_tcp_sequence_number);
-+
- /* Generate secure starting point for ephemeral IPV4 transport port search */
- u32 secure_ipv4_port_ephemeral(__be32 saddr, __be32 daddr, __be16 dport)
- {