refresh generic 2.6.24 patches to match upstream style
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 171-netfilter_tarpit.patch
index 690d18ce89c6337ea0a743275e4b6d2dbcce5821..2ebb669573969728d1cf95daf37600e1c169940c 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/net/netfilter/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/net/netfilter/Kconfig
-+++ linux-2.6.24.7/net/netfilter/Kconfig
-@@ -401,6 +401,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
+--- a/net/netfilter/Kconfig
++++ b/net/netfilter/Kconfig
+@@ -401,6 +401,23 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -26,11 +24,9 @@ Index: linux-2.6.24.7/net/netfilter/Kconfig
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
        depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.24.7/net/netfilter/Makefile
-===================================================================
---- linux-2.6.24.7.orig/net/netfilter/Makefile
-+++ linux-2.6.24.7/net/netfilter/Makefile
-@@ -47,6 +47,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG) 
+--- a/net/netfilter/Makefile
++++ b/net/netfilter/Makefile
+@@ -47,6 +47,7 @@
  obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE) += xt_NFQUEUE.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK) += xt_SECMARK.o
@@ -38,10 +34,8 @@ Index: linux-2.6.24.7/net/netfilter/Makefile
  obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
-Index: linux-2.6.24.7/net/netfilter/xt_TARPIT.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.24.7/net/netfilter/xt_TARPIT.c
++++ b/net/netfilter/xt_TARPIT.c
 @@ -0,0 +1,279 @@
 +/*
 + * Kernel module to capture and hold incoming TCP connections using