[kernel] remove 2.6.24, no target is relying on it
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 410-gpio_buttons.patch
diff --git a/target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch
deleted file mode 100644 (file)
index 31d40c9..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -183,4 +183,20 @@ config HP_SDC_RTC
-         Say Y here if you want to support the built-in real time clock
-         of the HP SDC controller.
-+config INPUT_GPIO_BUTTONS
-+      tristate "Polled GPIO buttons interface"
-+      depends on GENERIC_GPIO
-+      select INPUT_POLLDEV
-+      help
-+        This driver implements support for buttons connected
-+        to GPIO pins of various CPUs (and some other chips).
-+
-+        Say Y here if your device has buttons connected
-+        directly to such GPIO pins.  Your board-specific
-+        setup logic must also provide a platform device,
-+        with configuration data saying which GPIOs are used.
-+
-+        To compile this driver as a module, choose M here: the
-+        module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -18,3 +18,4 @@ obj-$(CONFIG_INPUT_POWERMATE)                += powerm
- obj-$(CONFIG_INPUT_YEALINK)           += yealink.o
- obj-$(CONFIG_HP_SDC_RTC)              += hp_sdc_rtc.o
- obj-$(CONFIG_INPUT_UINPUT)            += uinput.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS)      += gpio_buttons.o