generic 2.6.24 support
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 902-darwin_scripts_include.patch
diff --git a/target/linux/generic-2.6/patches-2.6.24/902-darwin_scripts_include.patch b/target/linux/generic-2.6/patches-2.6.24/902-darwin_scripts_include.patch
new file mode 100644 (file)
index 0000000..2a3a1e0
--- /dev/null
@@ -0,0 +1,114 @@
+Index: linux-2.6.23-rc6/scripts/genksyms/parse.c_shipped
+===================================================================
+--- linux-2.6.23-rc6.orig/scripts/genksyms/parse.c_shipped     2007-09-21 16:23:51.000000000 +0800
++++ linux-2.6.23-rc6/scripts/genksyms/parse.c_shipped  2007-09-21 16:24:10.000000000 +0800
+@@ -144,7 +144,9 @@
+ #include <assert.h>
++#ifndef __APPLE__
+ #include <malloc.h>
++#endif
+ #include "genksyms.h"
+ static int is_typedef;
+Index: linux-2.6.23-rc6/scripts/genksyms/parse.y
+===================================================================
+--- linux-2.6.23-rc6.orig/scripts/genksyms/parse.y     2007-09-21 16:23:51.000000000 +0800
++++ linux-2.6.23-rc6/scripts/genksyms/parse.y  2007-09-21 16:24:10.000000000 +0800
+@@ -24,7 +24,9 @@
+ %{
+ #include <assert.h>
++#ifndef __APPLE__
+ #include <malloc.h>
++#endif
+ #include "genksyms.h"
+ static int is_typedef;
+Index: linux-2.6.23-rc6/scripts/kallsyms.c
+===================================================================
+--- linux-2.6.23-rc6.orig/scripts/kallsyms.c   2007-09-21 16:23:51.000000000 +0800
++++ linux-2.6.23-rc6/scripts/kallsyms.c        2007-09-21 16:24:10.000000000 +0800
+@@ -28,6 +28,35 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <ctype.h>
++#ifdef __APPLE__
++/* Darwin has no memmem implementation, this one is ripped of the uClibc-0.9.28 source */
++void *memmem (const void *haystack, size_t haystack_len,
++                          const void *needle,  size_t needle_len)
++{
++  const char *begin;
++  const char *const last_possible
++    = (const char *) haystack + haystack_len - needle_len;
++
++  if (needle_len == 0)
++    /* The first occurrence of the empty string is deemed to occur at
++       the beginning of the string.  */
++    return (void *) haystack;
++
++  /* Sanity check, otherwise the loop might search through the whole
++     memory.  */
++  if (__builtin_expect (haystack_len < needle_len, 0))
++    return NULL;
++
++  for (begin = (const char *) haystack; begin <= last_possible; ++begin)
++    if (begin[0] == ((const char *) needle)[0] &&
++        !memcmp ((const void *) &begin[1],
++                 (const void *) ((const char *) needle + 1),
++                 needle_len - 1))
++      return (void *) begin;
++
++  return NULL;
++}
++#endif
+ #define KSYM_NAME_LEN         128
+Index: linux-2.6.23-rc6/scripts/kconfig/Makefile
+===================================================================
+--- linux-2.6.23-rc6.orig/scripts/kconfig/Makefile     2007-09-21 16:23:51.000000000 +0800
++++ linux-2.6.23-rc6/scripts/kconfig/Makefile  2007-09-21 16:24:10.000000000 +0800
+@@ -88,6 +88,9 @@
+ # we really need to do so. (Do not call gcc as part of make mrproper)
+ HOST_EXTRACFLAGS = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ccflags)
+ HOST_LOADLIBES   = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ldflags $(HOSTCC))
++ifeq ($(shell uname -s),Darwin)
++HOST_LOADLIBES  += -lncurses
++endif
+ HOST_EXTRACFLAGS += -DLOCALE
+Index: linux-2.6.23-rc6/scripts/mod/mk_elfconfig.c
+===================================================================
+--- linux-2.6.23-rc6.orig/scripts/mod/mk_elfconfig.c   2007-09-21 16:23:51.000000000 +0800
++++ linux-2.6.23-rc6/scripts/mod/mk_elfconfig.c        2007-09-21 16:24:10.000000000 +0800
+@@ -1,7 +1,11 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#ifndef __APPLE__
+ #include <elf.h>
++#else
++#include "../../../../../tools/sstrip/include/elf.h"
++#endif
+ int
+ main(int argc, char **argv)
+Index: linux-2.6.23-rc6/scripts/mod/modpost.h
+===================================================================
+--- linux-2.6.23-rc6.orig/scripts/mod/modpost.h        2007-09-21 16:23:51.000000000 +0800
++++ linux-2.6.23-rc6/scripts/mod/modpost.h     2007-09-21 16:24:10.000000000 +0800
+@@ -7,7 +7,11 @@
+ #include <sys/mman.h>
+ #include <fcntl.h>
+ #include <unistd.h>
++#ifndef __APPLE__
+ #include <elf.h>
++#else
++#include "../../../../../tools/sstrip/include/elf.h"
++#endif
+ #include "elfconfig.h"