[kernel] remove 2.6.24, no target is relying on it
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 921-gpio_spi_driver.patch
diff --git a/target/linux/generic-2.6/patches-2.6.24/921-gpio_spi_driver.patch b/target/linux/generic-2.6/patches-2.6.24/921-gpio_spi_driver.patch
deleted file mode 100644 (file)
index 1ad1932..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/drivers/spi/Kconfig
-+++ b/drivers/spi/Kconfig
-@@ -100,6 +100,11 @@ config SPI_BUTTERFLY
-         inexpensive battery powered microcontroller evaluation board.
-         This same cable can be used to flash new firmware.
-+config SPI_GPIO
-+      tristate "GPIO API based bitbanging SPI controller"
-+      depends on SPI_MASTER && GENERIC_GPIO && EXPERIMENTAL
-+      select SPI_BITBANG
-+
- config SPI_IMX
-       tristate "Freescale iMX SPI controller"
-       depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
---- a/drivers/spi/Makefile
-+++ b/drivers/spi/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN)                       += spi_bfin5xx.
- obj-$(CONFIG_SPI_BITBANG)             += spi_bitbang.o
- obj-$(CONFIG_SPI_AU1550)              += au1550_spi.o
- obj-$(CONFIG_SPI_BUTTERFLY)           += spi_butterfly.o
-+obj-$(CONFIG_SPI_GPIO)                        += spi_gpio.o
- obj-$(CONFIG_SPI_IMX)                 += spi_imx.o
- obj-$(CONFIG_SPI_LM70_LLP)            += spi_lm70llp.o
- obj-$(CONFIG_SPI_PXA2XX)              += pxa2xx_spi.o