add generic 2.6.26 patches/files
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.26 / 004-extra_optimization.patch
diff --git a/target/linux/generic-2.6/patches-2.6.26/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.26/004-extra_optimization.patch
new file mode 100644 (file)
index 0000000..d3898f1
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -533,6 +533,9 @@
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS     += $(NOSTDINC_FLAGS)
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)