makes ledtrignetdev work on .26 and fix whitespaces
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.26 / 402-ledtrig_netdev.patch
diff --git a/target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch b/target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch
new file mode 100644 (file)
index 0000000..1dcdad6
--- /dev/null
@@ -0,0 +1,25 @@
+Index: linux-2.6.26/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.26.orig/drivers/leds/Kconfig     2008-08-04 15:03:44.000000000 +0200
++++ linux-2.6.26/drivers/leds/Kconfig  2008-08-04 15:04:18.000000000 +0200
+@@ -200,4 +200,11 @@
+       tristate "LED Morse Trigger"
+       depends on LEDS_TRIGGERS
++config LEDS_TRIGGER_NETDEV
++      tristate "LED Netdev Trigger"
++      depends on LEDS_TRIGGERS
++      help
++        This allows LEDs to be controlled by network device activity.
++        If unsure, say Y.
++
+ endif # NEW_LEDS
+Index: linux-2.6.26/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.26.orig/drivers/leds/Makefile    2008-08-04 15:03:40.000000000 +0200
++++ linux-2.6.26/drivers/leds/Makefile 2008-08-04 15:04:29.000000000 +0200
+@@ -29,3 +29,4 @@
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT)  += ledtrig-heartbeat.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
++obj-$(CONFIG_LEDS_TRIGGER_NETDEV)      += ledtrig-netdev.o