port generic and ixp4xx kernel patches to 2.6.27 (compiles except for iptables, but...
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.27 / 620-phy_adm6996.patch
diff --git a/target/linux/generic-2.6/patches-2.6.27/620-phy_adm6996.patch b/target/linux/generic-2.6/patches-2.6.27/620-phy_adm6996.patch
new file mode 100644 (file)
index 0000000..2393843
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -66,6 +66,11 @@
+       ---help---
+         Supports the Realtek 821x PHY.
++config ADM6996_PHY
++      tristate "Driver for ADM6996 switches"
++      ---help---
++        Currently supports the ADM6996F switch
++
+ config FIXED_PHY
+       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -12,6 +12,7 @@
+ obj-$(CONFIG_VITESSE_PHY)     += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY)    += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
++obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o