use the openwrt lzma options for now
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.30 / 998-openwrt_lzma_options.patch
diff --git a/target/linux/generic-2.6/patches-2.6.30/998-openwrt_lzma_options.patch b/target/linux/generic-2.6/patches-2.6.30/998-openwrt_lzma_options.patch
new file mode 100644 (file)
index 0000000..8e05052
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -204,4 +204,4 @@ cmd_bzip2 = (bzip2 -9 < $< && $(size_app
+ # ---------------------------------------------------------------------------
+ quiet_cmd_lzma = LZMA    $@
+-cmd_lzma = (lzma -9 -c $< && $(size_append) $<) >$@ || (rm -f $@ ; false)
++cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2