rename target/linux/generic-2.6 to generic
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.33 / 410-gpio_buttons.patch
diff --git a/target/linux/generic-2.6/patches-2.6.33/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.33/410-gpio_buttons.patch
deleted file mode 100644 (file)
index b762dde..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -319,4 +319,20 @@ config INPUT_PCAP
-         To compile this driver as a module, choose M here: the
-         module will be called pcap_keys.
-+config INPUT_GPIO_BUTTONS
-+      tristate "Polled GPIO buttons interface"
-+      depends on GENERIC_GPIO
-+      select INPUT_POLLDEV
-+      help
-+        This driver implements support for buttons connected
-+        to GPIO pins of various CPUs (and some other chips).
-+
-+        Say Y here if your device has buttons connected
-+        directly to such GPIO pins.  Your board-specific
-+        setup logic must also provide a platform device,
-+        with configuration data saying which GPIOs are used.
-+
-+        To compile this driver as a module, choose M here: the
-+        module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -30,4 +30,5 @@ obj-$(CONFIG_INPUT_WINBOND_CIR)              += winb
- obj-$(CONFIG_INPUT_WISTRON_BTNS)      += wistron_btns.o
- obj-$(CONFIG_INPUT_WM831X_ON)         += wm831x-on.o
- obj-$(CONFIG_INPUT_YEALINK)           += yealink.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS)      += gpio_buttons.o