ar71xx: fix oprofile support
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.34 / 208-mips_oprofile_fix.patch
diff --git a/target/linux/generic-2.6/patches-2.6.34/208-mips_oprofile_fix.patch b/target/linux/generic-2.6/patches-2.6.34/208-mips_oprofile_fix.patch
new file mode 100644 (file)
index 0000000..0cbf4ed
--- /dev/null
@@ -0,0 +1,48 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -49,7 +49,9 @@ ifneq ($(SUBARCH),$(ARCH))
+ endif
+ ifndef CONFIG_FUNCTION_TRACER
+-cflags-y := -ffunction-sections
++  ifndef CONFIG_PROFILING
++    cflags-y := -ffunction-sections
++  endif
+ endif
+ ifdef CONFIG_FUNCTION_GRAPH_TRACER
+   ifndef KBUILD_MCOUNT_RA_ADDRESS
+--- a/arch/mips/oprofile/op_model_mipsxx.c
++++ b/arch/mips/oprofile/op_model_mipsxx.c
+@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
+       }
+ }
++static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
++{
++      return mipsxx_perfcount_handler();
++}
++
+ static int __init mipsxx_init(void)
+ {
+       int counters;
+@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
+       save_perf_irq = perf_irq;
+       perf_irq = mipsxx_perfcount_handler;
++      if (cp0_perfcount_irq >= 0)
++              return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
++                      IRQF_SHARED, "Perfcounter", save_perf_irq);
++
+       return 0;
+ }
+@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
+ {
+       int counters = op_model_mipsxx_ops.num_counters;
++      if (cp0_perfcount_irq >= 0)
++              free_irq(cp0_perfcount_irq, save_perf_irq);
++
+       counters = counters_per_cpu_to_total(counters);
+       on_each_cpu(reset_counters, (void *)(long)counters, 1);