generic-2.6: add kernel 2.6.35 preliminary support (patches)
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.35 / 670-phy_ip175c.patch
diff --git a/target/linux/generic-2.6/patches-2.6.35/670-phy_ip175c.patch b/target/linux/generic-2.6/patches-2.6.35/670-phy_ip175c.patch
new file mode 100644 (file)
index 0000000..e8c57ca
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -107,6 +107,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+       tristate "Driver for Marvell 88E6060 switches"
++config IP175C_PHY
++      tristate "Driver for IC+ IP175C/IP178C switches"
++      select SWCONFIG
++
+ config FIXED_PHY
+       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_BCM63XX_PHY)    += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+ obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
++obj-$(CONFIG_IP175C_PHY)      += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o