kernel: generic: add 3.10-rc1 support
[openwrt/svn-archive/archive.git] / target / linux / generic / patches-3.10 / 729-phy-rtl8367b.patch
diff --git a/target/linux/generic/patches-3.10/729-phy-rtl8367b.patch b/target/linux/generic/patches-3.10/729-phy-rtl8367b.patch
new file mode 100644 (file)
index 0000000..33d37fd
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -245,6 +245,10 @@ config RTL8367_PHY
+       tristate "Driver for the Realtek RTL8367R/M switches"
+       select SWCONFIG
++config RTL8367B_PHY
++      tristate "Driver fot the Realtek RTL8367R-VB switch"
++      select SWCONFIG
++
+ endif # RTL8366_SMI
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -27,6 +27,7 @@ obj-$(CONFIG_RTL8366_SMI)    += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY)    += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY)   += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY)     += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY)    += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY)      += micrel.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o