linux/3.3: build mdio_register_board_info into the kernel if PHYLIB is selected
[openwrt/svn-archive/archive.git] / target / linux / generic / patches-3.3 / 722-phy_mvswitch.patch
index 925cc4561ff285252db16ecf7b9ace821ad44a69..8b5bac2b1fc13bf0efcabe2f5986919a24ebf583 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -109,6 +109,9 @@ config ADM6996_PHY
+@@ -113,6 +113,9 @@ config ADM6996_PHY
          Currently supports the ADM6996FC and ADM6996M switches.
          Support for FC is very limited.
  
@@ -12,7 +12,7 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY)   += broadcom.o
+@@ -17,6 +17,7 @@ obj-$(CONFIG_BROADCOM_PHY)   += broadcom.o
  obj-$(CONFIG_BCM63XX_PHY)     += bcm63xx.o
  obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
  obj-$(CONFIG_ADM6996_PHY)     += adm6996.o