[ifxmips] refresh kernel patches
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / patches / 110-drivers.patch
index 9ce88f23250dcdbe788c43a92a109bc465263e26..64bb6cee3107ee4701e7a11ab8f74f4aa8a91ad8 100644 (file)
@@ -1,8 +1,8 @@
-Index: linux-2.6.25/drivers/char/Makefile
+Index: linux-2.6.25.4/drivers/char/Makefile
 ===================================================================
---- linux-2.6.25.orig/drivers/char/Makefile    2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/char/Makefile 2008-05-07 18:58:42.000000000 +0100
-@@ -112,6 +112,12 @@
+--- linux-2.6.25.4.orig/drivers/char/Makefile
++++ linux-2.6.25.4/drivers/char/Makefile
+@@ -112,6 +112,12 @@ obj-$(CONFIG_PS3_FLASH)           += ps3flash.o
  obj-$(CONFIG_JS_RTC)          += js-rtc.o
  js-rtc-y = rtc.o
  
@@ -15,20 +15,20 @@ Index: linux-2.6.25/drivers/char/Makefile
  # Files generated that shall be removed upon make clean
  clean-files := consolemap_deftbl.c defkeymap.c
  
-Index: linux-2.6.25/drivers/mtd/maps/Makefile
+Index: linux-2.6.25.4/drivers/mtd/maps/Makefile
 ===================================================================
---- linux-2.6.25.orig/drivers/mtd/maps/Makefile        2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/mtd/maps/Makefile     2008-05-07 18:58:42.000000000 +0100
-@@ -68,3 +68,4 @@
+--- linux-2.6.25.4.orig/drivers/mtd/maps/Makefile
++++ linux-2.6.25.4/drivers/mtd/maps/Makefile
+@@ -68,3 +68,4 @@ obj-$(CONFIG_MTD_PLATRAM)    += plat-ram.o
  obj-$(CONFIG_MTD_OMAP_NOR)    += omap_nor.o
  obj-$(CONFIG_MTD_MTX1)                += mtx-1_flash.o
  obj-$(CONFIG_MTD_INTEL_VR_NOR)        += intel_vr_nor.o
 +obj-$(CONFIG_MTD_IFXMIPS)  += ifxmips.o
-Index: linux-2.6.25/drivers/net/Kconfig
+Index: linux-2.6.25.4/drivers/net/Kconfig
 ===================================================================
---- linux-2.6.25.orig/drivers/net/Kconfig      2008-05-07 18:58:41.000000000 +0100
-+++ linux-2.6.25/drivers/net/Kconfig   2008-05-07 18:58:42.000000000 +0100
-@@ -351,6 +351,12 @@
+--- linux-2.6.25.4.orig/drivers/net/Kconfig
++++ linux-2.6.25.4/drivers/net/Kconfig
+@@ -351,6 +351,12 @@ config MACB
  
  source "drivers/net/arm/Kconfig"
  
@@ -41,11 +41,11 @@ Index: linux-2.6.25/drivers/net/Kconfig
  config AX88796
        tristate "ASIX AX88796 NE2000 clone support"
        depends on ARM || MIPS || SUPERH
-Index: linux-2.6.25/drivers/serial/Kconfig
+Index: linux-2.6.25.4/drivers/serial/Kconfig
 ===================================================================
---- linux-2.6.25.orig/drivers/serial/Kconfig   2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/serial/Kconfig        2008-05-08 07:53:18.000000000 +0100
-@@ -1327,6 +1327,14 @@
+--- linux-2.6.25.4.orig/drivers/serial/Kconfig
++++ linux-2.6.25.4/drivers/serial/Kconfig
+@@ -1327,6 +1327,14 @@ config SERIAL_OF_PLATFORM
          Currently, only 8250 compatible ports are supported, but
          others can easily be added.
  
@@ -60,21 +60,21 @@ Index: linux-2.6.25/drivers/serial/Kconfig
  config SERIAL_QE
        tristate "Freescale QUICC Engine serial port support"
        depends on QUICC_ENGINE
-Index: linux-2.6.25/drivers/serial/Makefile
+Index: linux-2.6.25.4/drivers/serial/Makefile
 ===================================================================
---- linux-2.6.25.orig/drivers/serial/Makefile  2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/serial/Makefile       2008-05-07 18:58:42.000000000 +0100
-@@ -66,4 +66,5 @@
+--- linux-2.6.25.4.orig/drivers/serial/Makefile
++++ linux-2.6.25.4/drivers/serial/Makefile
+@@ -66,4 +66,5 @@ obj-$(CONFIG_SERIAL_UARTLITE) += uartlit
  obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
  obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
  obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
 +obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
  obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
-Index: linux-2.6.25/drivers/watchdog/Makefile
+Index: linux-2.6.25.4/drivers/watchdog/Makefile
 ===================================================================
---- linux-2.6.25.orig/drivers/watchdog/Makefile        2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/watchdog/Makefile     2008-05-07 18:58:42.000000000 +0100
-@@ -96,6 +96,7 @@
+--- linux-2.6.25.4.orig/drivers/watchdog/Makefile
++++ linux-2.6.25.4/drivers/watchdog/Makefile
+@@ -96,6 +96,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
  obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
  obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
  obj-$(CONFIG_TXX9_WDT) += txx9wdt.o