turn the IXP4xx microcode check into a prereq check so that the error message is...
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx-2.6 / image / npe-ucode / Makefile
index 7dc476b6b14f1b79f19c19a6b6f2c59f980e76ba..1f61570dc41c603b391056edbea23ff413d34f06 100644 (file)
@@ -14,7 +14,6 @@ PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=IPL_ixp400NpeLibrary-2_3.zip
-PKG_SOURCE_URL:=http://www.intel.com/design/network/products/npfamily/ixp400_current.htm
 PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)/ $(DL_DIR)/$(PKG_SOURCE)
 
 include $(INCLUDE_DIR)/unpack.mk
@@ -32,12 +31,6 @@ $(PKG_BUILD_DIR)/NPE-B: $(PKG_BUILD_DIR)/.prepared
          $(HOSTCC) -Wall IxNpeMicrocode.c -o IxNpeMicrocode ; \
          ./IxNpeMicrocode -be )
 
-$(DL_DIR)/$(PKG_SOURCE):
-       mkdir -p $(DL_DIR)
-       echo "You must manually download $(PKG_SOURCE) from $(PKG_SOURCE_URL) and put it in $(DL_DIR)."
-       echo "You will need to agree to the Intel Public License to do so - please do read it!"
-       false
-
 download: $(DL_DIR)/$(PKG_SOURCE)
 prepare: $(PKG_BUILD_DIR)/.prepared
 compile: $(PKG_BUILD_DIR)/NPE-B