Add support for NAS100d apex builds, and deploy apex binaries
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / image / Makefile
index e5368fbca4811b93f6d298e5d2653be56f286771..ff3e501e47f96caa7e091e0dc51fde2d5777860f 100644 (file)
@@ -9,21 +9,22 @@ include $(INCLUDE_DIR)/image.mk
 
 define Image/Build/slug
        BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-               -L $(KDIR)/apex-nslu2-armeb.bin \
+               -L $(BIN_DIR)/apex-nslu2-armeb.bin \
                -k $(BIN_DIR)/openwrt-nslu2-zImage \
                -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
                -p -o $(BIN_DIR)/openwrt-nslu2-$(1).bin
        BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-               -F -L $(KDIR)/apex-nslu2-16mb-armeb.bin \
+               -F -L $(BIN_DIR)/apex-nslu2-16mb-armeb.bin \
                -k $(BIN_DIR)/openwrt-nslu2-zImage \
                -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
                -p -o $(BIN_DIR)/openwrt-nslu2-$(1)-16mb.bin
 endef
 
 define Build/Compile
+       mkdir -p $(BIN_DIR)
        $(MAKE) -C apex \
                BUILD_DIR="$(KDIR)" \
-               TARGET="$(KDIR)" \
+               TARGET="$(BIN_DIR)" \
                compile 
 endef