[target/leon]: add preliminary LEON support
[openwrt/svn-archive/archive.git] / target / linux / leon / image / Makefile
diff --git a/target/linux/leon/image/Makefile b/target/linux/leon/image/Makefile
new file mode 100644 (file)
index 0000000..2be550e
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+       cp $(LINUX_DIR)/arch/sparc/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+       mkdir -p $(BIN_DIR)
+       cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+endef
+
+$(eval $(call BuildImage))