mcs814x: add support for 3.18
[openwrt/svn-archive/archive.git] / target / linux / mcs814x / patches-3.18 / 011-mcs814x_internal_phy.patch
diff --git a/target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch b/target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch
new file mode 100644 (file)
index 0000000..20d5add
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -164,6 +164,10 @@ config RTL8306_PHY
+       tristate "Driver for Realtek RTL8306S switches"
+       select SWCONFIG
++config MCS814X_PHY
++      tristate "Driver for the Moschip MCS814x internal PHY"
++      depends on ARCH_MCS814X
++
+ config FIXED_PHY
+       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -51,3 +51,4 @@ obj-$(CONFIG_MDIO_SUN4I)     += mdio-sun4i.o
+ obj-$(CONFIG_MDIO_MOXART)     += mdio-moxart.o
+ obj-$(CONFIG_AMD_XGBE_PHY)    += amd-xgbe-phy.o
+ obj-$(CONFIG_MDIO_BCM_UNIMAC) += mdio-bcm-unimac.o
++obj-$(CONFIG_MCS814X_PHY)     += mcs814x.o