mpc83xx: moved to targets feed
[openwrt/svn-archive/archive.git] / target / linux / mpc83xx / patches-3.18 / 100-powerpc_create_fit_uImages.patch
diff --git a/target/linux/mpc83xx/patches-3.18/100-powerpc_create_fit_uImages.patch b/target/linux/mpc83xx/patches-3.18/100-powerpc_create_fit_uImages.patch
deleted file mode 100644 (file)
index ef58f14..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
---- a/arch/powerpc/Makefile
-+++ b/arch/powerpc/Makefile
-@@ -240,7 +240,9 @@ all: zImage
- # With make 3.82 we cannot mix normal and wildcard targets
- BOOT_TARGETS1 := zImage zImage.initrd uImage
--BOOT_TARGETS2 := zImage% dtbImage% treeImage.% cuImage.% simpleImage.% uImage.%
-+BOOT_TARGETS2 := uImage.fit.% zImage% dtbImage% treeImage.% cuImage.% \
-+               simpleImage.% uImage.%
-+
- PHONY += $(BOOT_TARGETS1) $(BOOT_TARGETS2)
-@@ -273,6 +275,7 @@ define archhelp
-   @echo '* zImage          - Build default images selected by kernel config'
-   @echo '  zImage.*        - Compressed kernel image (arch/$(ARCH)/boot/zImage.*)'
-   @echo '  uImage          - U-Boot native image format'
-+  @echo '  uImage.fit.<dt> - U-Boot Flattened Image Tree image format'
-   @echo '  cuImage.<dt>    - Backwards compatible U-Boot image for older'
-   @echo '                    versions which do not support device trees'
-   @echo '  dtbImage.<dt>   - zImage with an embedded device tree blob'
---- a/arch/powerpc/boot/.gitignore
-+++ b/arch/powerpc/boot/.gitignore
-@@ -14,6 +14,7 @@ kernel-vmlinux.strip.c
- kernel-vmlinux.strip.gz
- mktree
- uImage
-+uImage.fit.*
- cuImage.*
- dtbImage.*
- *.dtb
---- a/arch/powerpc/boot/Makefile
-+++ b/arch/powerpc/boot/Makefile
-@@ -357,6 +357,9 @@ $(obj)/uImage.initrd.%: vmlinux $(obj)/%
- $(obj)/uImage.%: vmlinux $(obj)/%.dtb $(wrapperbits)
-       $(call if_changed,wrap,uboot-$*,,$(obj)/$*.dtb)
-+$(obj)/uImage.fit.%: vmlinux $(obj)/%.dtb $(wrapperbits)
-+      $(call if_changed,wrap,uboot.fit,,$(obj)/$*.dtb)
-+
- $(obj)/cuImage.initrd.%: vmlinux $(obj)/%.dtb $(wrapperbits)
-       $(call if_changed,wrap,cuboot-$*,,$(obj)/$*.dtb,$(obj)/ramdisk.image.gz)
-@@ -399,6 +402,7 @@ zInstall: $(CONFIGURE) $(addprefix $(obj
- # anything not in $(targets)
- clean-files += $(image-) $(initrd-) cuImage.* dtbImage.* treeImage.* \
-+      uImage.* \
-       zImage zImage.initrd zImage.chrp zImage.coff zImage.holly \
-       zImage.miboot zImage.pmac zImage.pseries \
-       zImage.maple simpleImage.* otheros.bld *.dtb
---- a/arch/powerpc/boot/wrapper
-+++ b/arch/powerpc/boot/wrapper
-@@ -48,6 +48,9 @@ CROSS=
- # mkimage wrapper script
- MKIMAGE=$srctree/scripts/mkuboot.sh
-+# script to generate an .its file for uImage.fit.* images
-+MKITS=$srctree/scripts/mkits.sh
-+
- # directory for object and other files used by this script
- object=arch/powerpc/boot
- objbin=$object
-@@ -365,6 +368,21 @@ uboot-obs600)
-     if [ -z "$cacheit" ]; then
-       rm -f "$vmz"
-     fi
-+    exit 0
-+    ;;
-+uboot.fit)
-+    rm -f "$ofile"
-+    ${MKITS} -A ppc -C gzip -a $membase -e $membase -v $version \
-+      -d "$srctree/$dtb" -k "$srctree/$vmz" -o "$object/uImage.its"
-+
-+    # mkimage calls dtc for FIT images so use kernel dtc if necessary
-+    export PATH=$PATH:$srctree/scripts/dtc
-+
-+    ${MKIMAGE} -f "$object/uImage.its" "$ofile"
-+    rm "$object/uImage.its"
-+    if [ -z "$cacheit" ]; then
-+      rm -f "$vmz"
-+    fi
-     exit 0
-     ;;
- esac