linux/rb532: use kernel and initramfs tags on image generation
[openwrt/svn-archive/archive.git] / target / linux / rb532 / image / Makefile
index b7849cbda33e6d385d8b79b372aee0f10dc5c0e9..da4baaa48a0a25465918a000e6ca56df8e4e7b08 100644 (file)
@@ -28,8 +28,13 @@ define Image/Prepare
        $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
 endef
 
+VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux-kernel
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+       VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs
+endif
+
 define Image/BuildKernel
-       $(CP) $(KDIR)/loader.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
+       $(CP) $(KDIR)/loader.elf $(VMLINUX)
 endef
 
 define Image/cmdline/jffs2-64k
@@ -64,9 +69,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
        cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
        $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile   
   endef
-  define Image/BuildKernel
-       $(CP) $(KDIR)/loader.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
-  endef
 endif
 
 $(eval $(call BuildImage))