[uml] bump to 2.6.30.4, apply fix from [15119] to x86_64
[openwrt/svn-archive/archive.git] / target / linux / uml / patches / 002-gcc4_unfortify_source.patch
index b13e5df5218235ed7a6215ae59523f36592b9ee6..2be33d02a36f307d61c45eaab05384d46915b34f 100644 (file)
@@ -9,3 +9,13 @@
 +KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
 +
  KBUILD_CFLAGS += $(cflags-y)
+--- a/arch/um/Makefile-x86_64
++++ b/arch/um/Makefile-x86_64
+@@ -24,3 +24,7 @@ LINK-y += -m64
+ # Do unit-at-a-time unconditionally on x86_64, following the host
+ KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
++
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)