[kernel] update to 2.6.26.5 and 2.6.25.17
[openwrt/svn-archive/archive.git] / target / linux / x86 / Makefile
index ddb50e64046b894ee4b2e1acf05bad5eaf5f2d5f..9e46cfec3f7d56f80da69e1f7b6e434099d94cff 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
+FEATURES:=squashfs jffs2 ext2 vdi
+SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.25.17
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
-$(eval $(call Target,generic))
-$(eval $(call Target,mediacenter))
 $(eval $(call BuildTarget))
-$(eval $(call RequireCommand,mkisofs, \
+
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
        Please install mkisofs. \
 ))