[toolchain] gcc: only enable/disable TLS support in final stage (closes: #6788)
[openwrt/svn-archive/archive.git] / toolchain / gcc / Makefile
index 9c820f2feca59a81cfec96957c58a7ce9af7ca39..9536cc245bdac5b6685861a17ac450aeb464b6ca 100644 (file)
@@ -116,11 +116,6 @@ else
                --disable-libssp
 endif
 
-ifeq ($(CONFIG_TLS_SUPPORT),)
-  GCC_CONFIGURE+= \
-               --disable-tls
-endif
-
 ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
   GCC_CONFIGURE+= \
                --enable-biarch \
@@ -159,6 +154,14 @@ GCC_CONFIGURE_STAGE2:= \
                --enable-threads \
                --with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
+ifneq ($(CONFIG_TLS_SUPPORT),)
+  GCC_CONFIGURE_STAGE2+= \
+               --enable-tls
+else
+  GCC_CONFIGURE_STAGE2+= \
+               --disable-tls
+endif
+
 ifdef CONFIG_powerpc
   TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
 endif