gcc: set the isl/cloog prefix when graphite is enabled, disable it explicitly if...
[openwrt/svn-archive/archive.git] / toolchain / gcc / common.mk
index 5214765d6b228b98a037a9e1d4c42dc3f27bbb2d..0ac7de19f5c4822e76691589e740783610d5e2bc 100644 (file)
@@ -108,6 +108,16 @@ ifdef CONFIG_USE_UCLIBC
   export glibcxx_cv_c99_math_tr1=no
 endif
 
+ifdef CONFIG_GCC_USE_GRAPHITE
+  ifdef CONFIG_GCC_VERSION_4_8
+    GRAPHITE_CONFIGURE=--with-cloog=$(REAL_STAGING_DIR_HOST)
+  else
+    GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
+  endif
+else
+  GRAPHITE_CONFIGURE=--without-isl --without-cloog
+endif
+
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
        $(if $(shell gcc --version 2>&1 | grep LLVM), \