gcc: update gcc 5 to version 5.3.0
[openwrt/svn-archive/archive.git] / toolchain / gcc / patches / 5.3.0 / 940-no-clobber-stamp-bits.patch
diff --git a/toolchain/gcc/patches/5.3.0/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/5.3.0/940-no-clobber-stamp-bits.patch
new file mode 100644 (file)
index 0000000..a33ce24
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/libstdc++-v3/include/Makefile.in
++++ b/libstdc++-v3/include/Makefile.in
+@@ -1420,7 +1420,7 @@ stamp-bits: ${bits_headers}
+       @$(STAMP) stamp-bits
+ stamp-bits-sup: stamp-bits ${bits_sup_headers}
+-      @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
++      @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
+       @$(STAMP) stamp-bits-sup
+ stamp-c_base: ${c_base_headers}