[massive] add support for alternative C libraries (currently only glibc/eglibc)
[openwrt/svn-archive/archive.git] / toolchain / glibc-ports / patches / 2.7 / 401-mips_bootstrap_gcc_header_install.patch
diff --git a/toolchain/glibc-ports/patches/2.7/401-mips_bootstrap_gcc_header_install.patch b/toolchain/glibc-ports/patches/2.7/401-mips_bootstrap_gcc_header_install.patch
new file mode 100644 (file)
index 0000000..66f42e9
--- /dev/null
@@ -0,0 +1,11 @@
+diff -ruN glibc-ports-2.7-orig/sysdeps/mips/mips32/Makefile glibc-ports-2.7/sysdeps/mips/mips32/Makefile
+--- glibc-ports-2.7-orig/sysdeps/mips/mips32/Makefile  2003-03-29 09:15:28.000000000 +0100
++++ glibc-ports-2.7/sysdeps/mips/mips32/Makefile       2008-10-01 17:04:40.475005748 +0200
+@@ -1,3 +1,7 @@
++ifeq ($(filter -DBOOTSTRAP_GCC,$(CFLAGS)),)
+ ifeq ($(filter -mabi=32,$(CC)),)
+ CC += -mabi=32
+ endif
++else
++CC += -D"_MIPS_SZPTR=32"
++endif